Boot Loop



  • Server
    • FOG Version: 1.4.4
    • OS: Debian 8
    Client
    • Service Version: NA
    • OS: Windows 7 Ent
    Description

    I am trying to restore an image onto an Optiplex 5050. It looks like fog copies the image to the pc without issue, but after it reboots it never boots from the hard drive. I tried SANBOOT, EXIT and all the other options without any luck. Secure boot is disabled and the system is using UEFI.
    I am not sure what else to try.



  • @george1421 Thanks everyone.


  • Moderator

    @bigjim That is correct. You can only deploy a bios (legacy mode) image to legacy mode computers, and uefi images to uefi based computers. They are not interchangeable. This isn’t a limitation in fog, but more of a hardware consideration.

    You will need to create your vm and configure it for uefi mode before installing your reference OS. If your VM is based in vSphere there is an option setting in the setup configuration for the vm. To change it isn’t difficult. Just select the radio button for uefi. Then install your OS.



  • @tom-elliott Thanks for the clarification Tom. I want all of our new machines to be in UEFI mode. So I guess i need an image for the “old” legacy BIOS machines and an image for the UEFI machines, right?


  • Senior Developer

    @bigjim,

    Then UEFI is likely not how the VM is laid out. UEFI matters as it is not possible to “legacy” boot the machine if it is in UEFI mode. Using rEFInd would be the best bet to boot though I’m not sure that it can be done from undionly type files (ipxe, undionly, filenames with extensions of either: .pxe, kpxe, kkpxe).

    Can you show a picture of what you’re seeing? Also, if the BIOS of the optiplex machines is set to uefi, but the OS is in Legacy mode, there’s not much FOG can do to help this. You would need to specify the BIOS to boot in CSM/Legacy mode.



  • @fractal13 Yes it was created on a VM with legacy boot. It is windows 7 and was sysprepped.


  • Developer

    @bigjim How was the image you are deploying installed/created? If it is from a BIOS installed OS, it may not boot on a UEFI system. Sorry if this is a trivial answer.



  • Hi, Yes. The issue has something to do with the UEFI mode. In the past we always had the systems set in bios mode and images were created in bios mode. If i change the system to use BIOS mode it will boot from the hard drive, but crashes before windows starts. When rEFInd is used it just gtoes to the rEFInd about page.
    Thanks for the prompt reply


  • Senior Developer

    You tried rEFInd?


Log in to reply
 

405
Online

38993
Users

10713
Topics

101700
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.