Installing Custom Print Drivers FOG



  • Server
    • FOG Version: Running Version 16 | SVN Revision: 6079
    • OS: Debian 8.8
    Client
    • Service Version: 0.11.12
    • OS: Windows 7 Pro SP 1
    Description

    @Wayne-Workman
    I have created a new custom print driver to install for my new Canon printers / copiers… The driver will install fine with the FOG PrintManager Helper but it will give a UAC prompt due to the driver not being digitally signed from MS…

    Is their any way around this?

    Thanks!

    Joe

    Here is a FOG log…

    
    ------------------------------------------------------------------------------
    --------------------------------PrinterManager--------------------------------
    ------------------------------------------------------------------------------
     8/8/2017 10:57 AM Client-Info Client Version: 0.11.12
     8/8/2017 10:57 AM Client-Info Client OS:      Windows
     8/8/2017 10:57 AM Client-Info Server Version: 16
     8/8/2017 10:57 AM Middleware::Response Success
     8/8/2017 10:57 AM PrinterManager Adding printers
     8/8/2017 10:57 AM PrinterManager Admin Copier has already been configured
     8/8/2017 10:57 AM PrinterManager AE Lab has already been configured
     8/8/2017 10:57 AM PrinterManager Business Lab PCL6 has already been configured
     8/8/2017 10:57 AM PrinterManager Business Lab Printer PS already exists
     8/8/2017 10:58 AM PrinterManager Business Lab Richo Color Printer PCL6 already exists
     8/8/2017 10:58 AM PrinterManager Business Lab Richo Color Printer PS already exists
     8/8/2017 10:58 AM PrinterManager Elem Copier has already been configured
     8/8/2017 10:58 AM PrinterManager Elem Lab has already been configured
     8/8/2017 10:58 AM PrinterManager Elem Office has already been configured
     8/8/2017 10:58 AM PrinterManager Elem Teachers Lounge has already been configured
     8/8/2017 10:58 AM PrinterManager Elem Upstairs has already been configured
     8/8/2017 10:58 AM PrinterManager HS Back Hall has already been configured
     8/8/2017 10:58 AM PrinterManager HS Business Lab Savin already exists
     8/8/2017 10:58 AM PrinterManager HS Eng Lab has already been configured
     8/8/2017 10:58 AM PrinterManager HS Main Office already exists
     8/8/2017 10:58 AM PrinterManager HS Teachers Lounge already exists
     8/8/2017 10:58 AM PrinterManager HS Teachers Lounge Canon has already been configured
     8/8/2017 10:58 AM PrinterManager JH Lab has already been configured
     8/8/2017 10:58 AM PrinterManager JH Office has already been configured
     8/8/2017 10:58 AM PrinterManager Library Copier has already been configured
     8/8/2017 10:58 AM PrinterManager Library Office has already been configured
    


  • @joe-gill well done.



  • @wayne-workman

    SO… An update to this…

    I followed this Technet article and successfully signed my own driver file!

    https://technet.microsoft.com/en-us/library/dd919238(v=ws.10).aspx?f=255&MSPPError=-2147217396#bkmk_signstep2

    It was quite the process. I’m not an MCSE and prefer my feet in the Linux world. MS makes things so difficult to get done. I ended up having to download the SDK and WDK in order to get this done.

    This worked! After I set up the certificate on my local machine and allowed FOG to use the self signed drivers, it installed fine.

    SO… Their’s hope that I can get this done using GPO with the article below!

    https://technet.microsoft.com/en-us/library/dd919238(v=ws.10).aspx

    If you do this, you have to download the SDK package for your version of Windows Server… Why they can’t just package all of these things in Windows Server is beyond me!

    Ugh! MS… Can’t live with them… Can’t live without them!

    Thank you again!!!

    Cheers!

    Joe



  • @wayne-workman

    I’ll try that. This isn’t the first time I’ve seen this with FOG. I had a demo Toshiba copier that I had issues installing their custom driver from. I get a UAC prompt warning the driver isn’t signed. The funny thing is that in FOG it appears everything installs fine.

    I tried disabling the UAC for drivers in GPO but that did not work either.

    Hopefully self signing will work!

    Thanks for all of the links!

    Cheers!




 

386
Online

41.5k
Users

12.0k
Topics

113.5k
Posts