Tasks Management/Snapin Report Not Showing Pending Snapin Tasks



  • Server
    • FOG Version: 1.5.0 RC-6 Pulled/Updated 8/1
    • OS: CEntOS 7
    Description

    Snapin Log under Reports is not showing pending Snapin tasks. Snapins continue to run and show pending/complete on Snapin History for each machine. This ‘feature’ is fairly critical to monitoring progress during deployment activities.

    Also, I BELIEVE I’ve seen Snapin Tasks when one clicks on the Tasks Icon. They seem to be displaced to the Snapin report when a deployment task is created. I’m doing more testing and will get screenshots if I can.

    How is this supposed to work?

    Jim


  • Senior Developer

    To help clarify things.

    “Active Tasks” only shows the “jobs” that are to be performed, not every detail of that job as that would take up a lot of room about the “overall” task being completed.

    Active Snapin Tasks, is where you can see the individual tasks, the host it’s working from, and their current progress states. Of course they only show up when they’re in pending/progress states. When they’re completed they’re no longer considered active.

    This is NOT a report of tasks, but rather an “overview”.

    Report pages work differently, in that they should display completed items. Though I’ll admit it’s been a bit since I looked it over.


  • Senior Developer

    Confirmed and fixed in working branch. Thanks for reporting.



  • @jim-graczyk
    To add more info -

    I deployed several hosts with snapins. The Task Management Icon display showed the deployment with snapin, but once the imaging portion was done, the item disappeared from that screen. At no time was anything displayed on the Active Snapin Tasks screen. Periodically checking the Snapin History for each machine shows Queued, Complete, or Checked-In, yet nothing showed up under Active Snapin Tasks.

    What am I missing?

    Thanks,

    Jim



  • Tom,

    Sorry - bad terminology - and perhaps my expectations are off.

    I was expecting to see pending and active Snapin tasks when I have them pending or in progress somewhere under the Task Management icon - assuming this would be under Active Snapin Tasks. I see image tasks there that are pending and in progress under the Task Managment Icon, so I was expecting the same for . I wasn’t expecting to have to go to the Snapin Report to see Pending Snapin tasks.

    It was/am expecting to use the Task Management Icon and below to track things as they happen and to know when a task (image w snapins, image w/o snapins, deploy 1 snapin or deploy all snapins) are in pending and progress. I was/am expecting to use the reports to have a historic view what happened, when and results.

    Does a “Deploy” task (Image and Snapins) remain in the Active Task display until all snapins are deployed? If so, is there any way besides checking the machine Icon/Snapin History or the overall Reports/Snapin History to determine progress. With a lot deploying at once, that’s a lot of jumping around when several PC deployments are in play. I had expected to see Snapin-by-Snapin in the Active Snapin Tasks list.

    I’ve tried to test this but many of my snapins run very quickly. I’m not sure what I should be seeing where and when. The Task Management/Active Tasks list show pending tasks, as well as active tasks.

    Does the Active Snapind list function the same way?

    Thanks,

    Jim


  • Senior Developer

    I’m confused, can you more clearly describe the problem?

    Is it snapin reports having the issue? You mean you cannot see “in-progress” tasks on the snapin history report?


Log in to reply
 

368
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.