Storage node disk usage missing



  • Server
    • FOG Version: 1.5.0-RC-4
    • OS: CentOS 7.3
    Description

    Hello,

    I know that similar topics have already been opened on this subject, but none of solutions posted worked for me…

    I decided to restart from begining with a fresh intstall, so I installed latest version with git method on a clean VM. No errors during the script, I can update the database schema and then access to the WebUI with default credentials, but the storage disk usage is still not present.

    I also realized that the ‘fogstorage’ user created during installation was set without any password, so I made an update on mysql (from command line on local server) to set the same password as in the WebUI (STORAGENODE MYSQLPASS)
    After that I updated both .fogsettings and config.class.php files with this password but still not working.

    I read on other topics that rerun the installer script after updating those files can solve the problem, but the script fails on “Backing up database” whereas my proxy settings are correctly set in wgetrc file and in bashrc environment variables (with “export” command).

    I suppose that the bug is only “graphical” because clicking in the blank space give me correct informations about used and free space on the disk, but still embarassing because the next part is to add additional storage nodes …

    Any help is very welcome :)

    Thanking you in advance.



  • Ok I don’t know why, but creating a new user on the GUI made the disk usage come back !

    Maybe it has updated the db ? Really don’t know but IT WORKS ! You can mark it as “Solved”.

    Thanks for your help ;)



  • @tom-elliott That’s my master server so yes, this is the same node that I access the GUI from.


  • Senior Developer

    @hugo this is the same node that you access the GUI from? Or is GUI different? I ask because I added code that switched from always using http to access node information. If the nodes are all setup without https but you access the GUI with https it would have won’t even display the node in the list. Otherwise I don’t quite now for the moment.



  • @george1421 @Tom-Elliott Hi guys, just successfully reran the script after adding the fog_server_ip for the $no_proxy variable.

    So I’m now on 1.5.0-RC-6 but still the same problem, no Sotrage node disk usage on Dashboard …



  • @tom-elliott I don’t have access to the server now but my problem is exactly the same as this post, only difference is that in my case that’s a fresh install and not an upgrade :

    0_1501266720939_Capture d’écran 2017-07-28 à 20.30.03.png

    What do you mean by Information stored on the GUI ?

    And we talked about proxy because of the “Backing up database” failed that I have when trying to rerun the script.


  • Senior Developer

    can we see a picture of the problem please?

    Can you also include the Information as it’s stored on the GUI? Proxy is not used to get storage node information.



  • @george1421 Yes the problem is that I have no longer access to the server until monday morning… I did this config on a VM to post you the result but that’s not the real server (http:// is set on the good one).

    So I will add the fog_server_ip for the no_proxy variable on Monday and i’ll keep you in touch ;)


  • Moderator

    @hugo OK I wanted to make sure you had the no_proxy in there. Typically you would put your proxy settings in like this

    export http_proxy="http://<IP_Addr>:<Port>"
    export https_proxy="http://<IP_Addr>:<Port>"
    export ftp_proxy="http://<IP_Addr>:<Port>"
    no_proxy="127.0.0.1, <fog_server_ip>"
    

    For the proxy ones you need to ensure you have http:// in front of the proxy server address, and for no_proxy the loopback ip address and the network interface for the FOG server.



  • Yes that’s right, here’s what i got :

    0_1501261331027_set.JPG

    I can’t disclose the IP’s but the three lines are the same -> IP and Port of the proxy server


  • Moderator

    @hugo said in Storage node disk usage missing:

    whereas my proxy settings are correctly set in wgetrc file and in bashrc environment variables (with “export” command)

    Ok lets focus on this statement then.

    So your fog server is behind a proxy server right?

    If you key in the following command, please post the results here: set |grep proxy



  • Yeah sorry, it’s clear for me because of the time I spent on trying to solve it ahah.

    The original issue is the blank section for “Storage Node Disk Usage” on the dashboard.

    So :

    1. I can log into mysql with root user (with no password as set by default when installing) and with fogstorage user (with STORAGENODE MYSQLPASS)

    2. I can log on my FOG Server linux OS with fog account and password of .fogsettings.

    Then comes the second problem : The script always failed on “Backing up database” when I rerun it…


  • Moderator

    you have me a bit confused on where your original issue is. You are linking settings that should not be linked.

    First lets review your .fogsettings file (I don’t need to see it).

    What I need you to do is confirm a few things.

    1. You can log into mysql using the user id and passwords found in snmysqluser and snmysqlpass. These values need to be correct or fog will fall on its face. You just need to log into mysql using mysql -u <snmysqluser> -p and then enter snmysqlpass for the password. If that works then go on to the next step.
    2. Confirm that you can login to the FOG server linux OS using the user account referenced by user id fog and the password listed in the field password in /opt/fog/.fogsettings file.

    If those are set correctly then rerun the installer.

    After that is done look at the storage node setting for this fog server. Ensure that Management Username == fog and Management Password matches the password found in the password field in /opt/fog/.fogsettings.

    Don’t edit any other files.


Log in to reply
 

750
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.