Mysql database passord must be reset to get Fog working again



  • Server
    • FOG Version: 1.4.0
    • OS: Ubuntu Server 16.04
    Client
    • Service Version: N/A
    • OS: Win 10 Pro 64bit
    Description

    Hi,

    We have a recurring issue where fog stops working and the webportal shows a database error message. All computers that are started after this point will go into a boot loop.

    The workaround is to reset the mysql password with the following command.
    ALTER USER ‘root’@‘localhost’ IDENTIFIED WITH mysql_native_password BY ‘’;

    We have tested fog project version 1.3.0, 1.4.0 with ubuntu server 16.04.
    During installation we used the following command: sudo php_ver=‘7.0’ php_verAdds=’-7.0’ ./installfog.sh -y

    Is this a problem the fogproject is aware of, or have we done something completely wrong in our setup.

    The mysql password we use is blank, would that be a problem?

    Please let me know what other information I need to provide to find a solution for this problem, or if there are anything you want me to test. I do not have a way to reproduce the issue other than waiting for it to happen again, which is usually once a month on one of our servers.



  • Hi @Tom-Elliott,
    That might just be the solution. Not sure why, but I had the perception that having a db with no password was the recomanded way. Again, thanks for helping me out and for developing and giving support to this fantastic tool!


  • Senior Developer

    @Frode-Woldsund Or you could set a mysql password and just use it… This particular issue only occurs on DB’s that have no password defined. I don’t like that ubuntu keeps forcing the code after the user has defined it, but this should not be the case if the password is already set.



  • @Sebastian-Roth Thanks, It is much possible that this is due to unattended upgrades. I’ll have a look at the forum tread you posted and also check our configuration files. But as @Wayne-Workman said, switching to debian might just solve this more permanent.



  • @Wayne-Workman Thanks, I will surly try using debian as our default setup, if that is a more recomanded OS for the fog project.



  • To avoid this issue altogether, I’d suggest your next FOG server use Debian or CentOS.


  • Developer

    @Frode-Woldsund Might be caused by unattended upgrades, see here: https://forums.fogproject.org/topic/10006/ubuntu-is-fog-s-enemy

    Depending on when the issue comes up (e.g. after running the FOG installer) this might also be caused by passwords not matching up in the two different files /opt/fog/.fogsettings (settings used by the installer) and /var/www/fog/lib/fog/config.class.php (the active PHP config used to connect to the DB).


 

521
Online

41.8k
Users

12.3k
Topics

116.1k
Posts