Macbook Air Capture Fail


  • Developer

    @SlimJim Sorry, didn’t know that with ubuntu the hfsplus module is only part of the ARM/PowerPC kernels and one special lowlatency kernel that is not part of the live CD (see here). Looks like debian comes with hfsplus kernel module, so you might try the debian netboot iso or possibly grml should do it as well. Let’s hope those will boot on your Mac. Not all ISOs do.



  • @Sebastian-Roth
    Module doesn’t appear to be available…

    When I try to insert I get the following:

    root@ubuntu:~# modprobe hfsplus
    modprobe: ERROR: could not insert 'hfsplus': Input/output error
    
    root@ubuntu:~# dpkg -L hfsplus
    /.
    /usr
    /usr/share
    /usr/share/doc
    /usr/share/doc/hfsplus
    /usr/share/doc/hfsplus/copyright
    /usr/share/man
    /usr/share/man/man7
    /usr/share/man/man7/hfsplus.7.gz
    /usr/share/man/man1
    /usr/share/man/man1/hpls.1.gz
    /usr/share/man/man1/hpcd.1.gz
    /usr/share/man/man1/hpumount.1.gz
    /usr/share/man/man1/hpmkdir.1.gz
    /usr/share/man/man1/hppwd.1.gz
    /usr/share/man/man1/hprm.1.gz
    /usr/share/man/man1/hpmount.1.gz
    /usr/share/man/man1/hpfsck.1.gz
    /usr/share/man/man1/hpcopy.1.gz
    /usr/bin
    /usr/bin/hpmkdir
    /usr/bin/hpcopy
    /usr/bin/hprm
    /usr/bin/hpmount
    /usr/bin/hpumount
    /usr/bin/hpfsck
    /usr/bin/hpls
    /usr/bin/hppwd
    /usr/bin/hpcd
    /usr/share/doc/hfsplus/changelog.Debian.gz
    root@ubuntu:~# modprobe -l | grep hfs
    

  • Developer

    @SlimJim said in Macbook Air Capture Fail:

    mount: unknown filesystem type 'hfsplus’

    You might need to load the kernel driver:

    sudo -i
    modprobe hfsplus
    mkdir -p /macmnt
    mount -t /dev/sda2 /mnt
    dmesg | tail
    


  • @Sebastian-Roth Here’s the complete output:

    root@ubuntu:/home/ubuntu# fsck.hfsplus -f /dev/sda2
    ** /dev/sda2
    ** Checking HFS Plus volume.
    ** Checking Extents Overflow file.
    ** Checking Catalog file.
    ** Checking multi-linked files.
    ** Checking Catalog hierarchy.
    ** Checking Extended Attributes file.
    ** Checking volume bitmap.
    ** Checking volume information.
    ** The volume Macintosh HD appears to be OK.
    root@ubuntu:/home/ubuntu# mount -t hfsplus /dev/sda2 /mnt; dmesg | tail
    mount: unknown filesystem type 'hfsplus'
    bash: /usr/bin/tail: Input/output error
    

    Am I missing something? If I ran the command as the ubuntu user without sudo it says only root is allowed to use the mount -t option.



  • @Sebastian-Roth Yes, the fsck in single-user mode completed without errors and I get the same error when trying a capture, just booted to the ubuntu live cd, so I will update with my findings.


  • Developer

    @SlimJim So you did a /sbin/fsck -fy in single user mode on that Mac before imaging? You could try booting a live linux on that machine and run fsck.hfsplus -f /dev/sda2 and mount -t hfsplus /dev/sda2 /mnt; dmesg | tail by hand. Maybe this will give is some more information. Post a picture of the output here.

    Posting the actual error text here as well just in case someone else is running into this: hfsplusclone.c: bitmap count error, used:xxx, mbitmap:yyy


  • Moderator

    I don’t have a clue about Macs, but the error message is a bit misleading. Its parclone that is having an issue and not reporting cleanly to FOG. This generally happens when there is an error in the disk. I know you said you just ran fsck to check the disk. But usually when partclone blows up there is an issue with the disk or its format.



  • I’ve also made sure everything was shutdown cleanly n fsck completed just fine


Log in to reply
 

473
Online

5.6k
Users

12.9k
Topics

121.1k
Posts