No web GUI after update



  • Server
    • FOG Version: 1.4.4 (Dev)
    • OS: Ubuntu 14.04.5 LTS
    Client
    • Service Version: n/a
    • OS: n/a
    Description

    I’m not sure whether this should be here or in the dev forum. Please correct me if I’m wrong.

    I ran “sudo apt-get update” and “sudo apt-get upgrade” on the server. Then I tried to update by manually downloading 1.4.0 (stable) and running install.sh, but this gave me a blank white screen when trying to load the GUI. I then remembered that I had used GIT and the dev branch prior to this to get some things working with Windows 10. I then pulled the latest dev branch and ran install.sh again. This gave me pretty much the same results, blank screen (redirecting to ?node=schema but missing index.php). A couple reboots, Ubuntu updates, and google searches later I’m worried I’ve totally screwed it up and will need to start fresh. I can recreate the images if I need to, but obviously it would be nice if I could revive this one and not have to start from fresh.

    My apache log is giving a PHP error, so maybe there is hope?

    [Wed Jul 12 08:12:22.284942 2017] [php7:error] [pid 5337] [client 192.168.8.116:63297] PHP Fatal error: Uncaught Error: Call to a member function lastInsertId() on boolean in /var/www/html/fog/lib/db/pdodb.class.php:443\nStack trace:\n#0 /var/www/html/fog/lib/fog/fogcontroller.class.php(527): PDODB->insertId()\n#1 /var/www/html/fog/lib/fog/hookmanager.class.php(59): FOGController->save()\n#2 /var/www/html/fog/lib/fog/fogpagemanager.class.php(82): HookManager->processEvent(‘SEARCH_PAGES’, Array)\n#3 [internal function]: FOGPageManager->__construct()\n#4 /var/www/html/fog/lib/fog/fogbase.class.php(457): ReflectionClass->newInstanceArgs(Array)\n#5 /var/www/html/fog/management/index.php(23): FOGBase::getClass(‘FOGPageManager’)\n#6 {main}\n thrown in /var/www/html/fog/lib/db/pdodb.class.php on line 443


  • Moderator

    @mmcspadden I closed it for you and gave Quazz the bonus points.



  • Now how do I mark it as solved?



  • Success!
    Thanks Quazz. I was able to get it going with that documentation. For anyone coming afterwards here were my steps.

    • Found that there was no fog user in MYSQL (at least it would not let me drop it)
    • Created fog user with a blank password
    • Granted permissions to fog db for fog user
    • Realized that I had set a root password on mysql
    • Found the password in /var/www/fog/lib/fog/Config.class.php
    • Copied it over to the proper place in /opt/fog/.fogsettings
    • Ran dpkg-reconfigure mysql-server-5.5
    • Finally re-ran installfog.sh

    I now have a GUI back and am able to image computers.


  • Moderator

    I see two problems.

    FOG cannot connect to the database and the Web folder is (possibly) messed up.

    Let’s fix the database login first, as that is the biggest issue.

    https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_MySQL

    Should be pretty detailed. On a default install, the username will be root, no password and host is localhost



  • The forums do not seem to allow me to upload a text file, so I had to do this in a series of screenshots. I went through the log (didn’t know that one existed, so thanks), and took a screenshot of anything that errored. I see a couple things that could cause problems, seems like a wrong pass or lack of pass in one section, also complains about not having the PHP module for Apache, although PHP is running later in the log.

    3_1500045237660_Capture1.PNG

    2_1500045237660_Capture2.PNG

    1_1500045237660_Capture3.PNG

    0_1500045237660_Capture4.PNG


  • Moderator

    What does the error log say in /root/fogproject/bin/error_logs ?



  • Hi Wayne,
    Thanks for the reply. I have used that page as a reference before. Were you referring to the clone directory at /root/fogproject? Or did you mean deleting the www directory info? I deleted the fogproject directory re-cloned with git, and re-ran installfog.sh, but with the same results. The only thing that appears to fail during the setup was backing up the database. See screenshot.

    0_1500042746297_Capture.PNG

    Should I try deleting the web directory? Or is it possible since I attempted to manually install Fog that there is another directory somewhere that is overriding this one?

    Thanks.


  • Moderator

    I’d just delete the old fog repository on the box (the one you cloned from before during the git process). Then just re-clone the fog repository (stay on the master branch) and install the latest, that should fix things.

    This is an older article but is still accurate: https://wiki.fogproject.org/wiki/index.php?title=Upgrade_to_trunk
    In there, there’s two videos to help you along. Again, what I recommend for you is to find the old repo clone and delete it, then just reclone and reinstall.


Log in to reply
 

357
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.