Switch latest ver. of Fog to undionly.kkpxe

  • Server
    • FOG Version: 1.4.4
    • OS: Ubuntu 12.04
    • Service Version:
    • OS:

    I am uploading an image to Fog from an HP ProBook 655 G3 laptop using a Realtek PCIe 2.64 controller and the undionly.kpxe file reports “No configuration methods succeeded” and quits.

    In the older version of Fog I was able to switch to the undionly.kkpxe and that fixed the issue but I’m having a heck of a time finding the settings for that in this version and searching the forums is bringing up information for older server versions.

    I’m using the Fog server as dhcp but the dhcpd.conf file looks very different and I’m not seeing the option 67 line to edit. I’m looking in the wrong spot and could use a hint.


  • Moderator

    @UCJared Excellent, I’m glad you have it worked out. ipxe.kpxe “should” work for all hardware nics, you may run into an odd-ball one where undionly.kpxe works better. The advantage of undionly.kpxe is that is smaller and quicker to load and usually a better chance of compatibility (except for those darn realtek chips).

  • @george1421
    Thanks for the clarification. The error is occurring before we reach the Fog menu.

    The dhcpd.conf file shows several class definitions and most of them point to ipxe.efi.

    I’m not using uefi on these laptops; they are all set to Legacy boot. I set the Legacy class file option to ipxe.kpxe …

    AND IT WORKED. Ah ha! I understand better now.

    Thanks so much for the help.

  • Moderator

    @UCJared We are not in FOS yet are we? If I remember correctly the “no configuration options” error was in iPXE. (a picture snapped with a mobile would tell the context of the error, its almost as important as the error itself). If this is iPXE then that is managed by your dhcp server (ipxe.pxe vs undionly.kpxe) that is all done before you make a FOG menu selection. If you are seeing the error after you make a fog menu selection then that is the FOS engine[ bzImage and init.xy] (customize linux OS for capturing and deploying images)

  • @george1421
    I’m sorry to report that I’m not sure how to do this now. If I remember correctly, the 1.3 Fog server had an option field in the web console to set the various kernels. I can’t find anywhere in the 1.4.4 web console to change to the ipxe.kpxe kernel.

  • @george1421
    Yes sir.
    I have several ProDesk 600 G3 PCs here that are imaging just fine. They are Intel chipsets and we seems to have good luck with those (fingers crossed).

    These ProBook 655s are AMD chipsets and they’ve been bad luck for me.

  • Moderator

    @UCJared And just for clarity its only the Probook 655 that has the issue. Other devices plugged into the same network port pxe boots just fine into the FOG iPXE menu?

  • Okay, I’m going to give this a try and report back.

  • Moderator

    @george1421 The undionly.xxxx files use the built in undi driver in the network adapter. Sometimes these drivers are a bit flaky. The ipxe.xxx ipxe kernels use the native ipxe drivers and not the sometimes flaky on board undi drivers in the network adapters.

  • Moderator

    ok then lets look at a different ipxe kernel. Lets change the ipxe kernel to ipxe.kpxe Those realtek nics have been a problem more often than not.

    Also make sure your firmware is updated on your pxe booting computer too.

    For your dhcp server you might want to review example 1 here, this is an ideal dhcp server configuration: https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence

  • Thanks for the quick reply. I saw that option listed in several older posts during my search and tried it. I connected the laptop to an 8-port dumb switch connected to the switch my fog server is on and the problem persists.

  • Moderator

    Can you test an idea I have. Please place a dumb (unmanaged) network switch between the pxe booting computer and the building switch. If this resolves the issue then you may be running into a spanning tree issue or a green ethernet issue. Just test this first and we will work towards step 2

Log in to reply