Advanced wake-up task for a group is queued but not performed



  • Server
    • FOG Version: 1.4.3
    • OS: ubuntu 16.04.2.
    Client
    • Service Version:
    • OS:
    Description

    Advanced wake-up task for a group is queued but not performed.

    Wake-up tasks (Basic Tasks -> Advanced) for a single host are performed correctly (and afterwards the already queued task for the same host as a member of a group is even removed from the queue list).

    Immediately performed Wake On Lan Power Management tasks are performed correcty too.



  • @Tom-Elliott you are right! That was the problem. I do not know why i have two instances - i will clear and fix it tomorrow! Thank you Tom!


  • Senior Developer

    @FritzBox360 You have two installations that are “separate” but functionally working from one location.

    Mind running:

    mv /var/www/fog /var/www/fog_old
    ln -s /var/www/html/fog /var/www/fog
    

    So that this type of problem doesn’t happen again?



  • @Tom-Elliott now it works :) not sure were the problem was … Thanks a lot!


  • Senior Developer

    @FritzBox360 then can you change the -O portion to state:

    wget -O /var/www/html/fog/lib/fog/group.class.php https://raw.githubusercontent.com/FOGProject/fogproject/c9431f0da0659fd5f6730b2a7e0ec0d38ad1f179/packages/web/lib/fog/group.class.php
    

    Also, please make sure there’s isn’t any erroneous spaces.



  • @Tom-Elliott, I cowardly run

    cp /var/www/fog/lib/fog/group.class.php /var/www/fog/lib/fog/group.class.php-bak
    

    I empty the MySQL task table in PHPMyAdmin and then run the command you requested:

    wget -O /var/www/fog/lib/fog/group.class.php https://raw.githubusercontent.com/FOGProject/fogproject/c9431f0da0659fd5f6730b2a7e0ec0d38ad1f179/packages/web/lib/fog/group.class.php
    

    No more error on group WOL. Thanks again



  • @Tom-Elliott yes, i run your command with an empty task table but nothing changed

    --2017-06-26 14:31:59--  https://raw.githubusercontent.com/FOGProject/fogproject                  /c9431f0da0659fd5f6730b2a7e0ec0d38ad1f179/packages/web/lib/fog/group.class.php
    Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.112.1                  33
    Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.112.                  133|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 29076 (28K) [text/plain]
    Saving to: ‘/var/www/fog/lib/fog/group.class.php’
    
    100%[======================================>] 29.076      --.-K/s   in 0,002s
    
    2017-06-26 15:31:59 (15,9 MB/s) - ‘/var/www/fog/lib/fog/group.class.php’ saved [                  29076/29076]
    
    

  • Senior Developer

    @FritzBox360 Did you run the command I requested, or just re-tried?



  • @Tom-Elliott Thanks a million, it worked ! (I just empty task table before applying.)



  • @Tom-Elliott yes, there are no active task. If i start a advanced wakeup for a group this task is hanging under the active tasks. I need to remove it manually.


  • Senior Developer

    @FritzBox360 Did you cancel the pre-existing task first and then try? I tested and saw the problem. The fix fixes the issue where it’s creating a tasking in the first place, it does not clear the task for you though.



  • @Tom-Elliott

    same problem - nothing changed! Is a restart of the machine or a service necessary?

    The task is till hanging in the active tasks tab but the client is startet via WOL.

    If you need further information just let me know ;)

    Thank you!

    Edit:
    If i start a task via the PowerManagement everything is fine. Just over the Basic Task - Advanced way i run into the problem.


  • Senior Developer

    Can you guys try this file:

    wget -O /var/www/fog/lib/fog/group.class.php https://raw.githubusercontent.com/FOGProject/fogproject/c9431f0da0659fd5f6730b2a7e0ec0d38ad1f179/packages/web/lib/fog/group.class.php
    

    With anyluck, WOL won’t create a tasking like normal tasks.

    This issue came from a prior fix to enable other non-init taskings that still needed to be queued in a similar init needed fashion. Sorry for the oversight.



  • hi
    Same problem here on Debian 8.7 and Fog version 1.4.30_1498466347619_VV3.jpg



  • Same problem here on Ubuntu 4.4.0-67-generic 88~14.04.1-Ubuntu

    If i start a wakeup task for a group, all clients starting up but trying to boot into a fog task. In the active tasks selection there is still a wakeup task “hanging” there.

    The clients get an error and reboot. If i delete the “hanging” task everything is okay and fog boots the disk.

    0_1498463838571_IMG_1283.JPG

    The strange thing is, that on friday was everything fine …



  • Server

    FOG Version: 1.4.2 / 1.43
    OS: Debian 8.8
    

    Client

    OS: Windows 7 32/64 bits
    

    Description

    Hi everyone,
    We have the same issue here on Debian 8.8 for group wake up.
    Tasks stay in “1” state and hosts start a deployment task that fail then reboot.

    Timezone and clock are ok. (/etc/php5/apache2/php.ini /etc/php5/cli/php.ini and gui: fog_tz_info)

    Any help would be appreciated.



  • Timezone the same in fog settings as in php.ini, ntp running.

    I do not schedule the wake-up event, direct execution.


  • Moderator

    Can you ensure that the timezone listed in the FOG settings is correct, as well as the timezone listed in the /etc/php.ini config file? Lastly ensure the linux clock on the FOG server is accurate.


 

492
Online

41.8k
Users

12.3k
Topics

116.0k
Posts