Install problem ubuntu 15.10



  • Server
    • FOG Version: 1.2
    • OS: Ubuntu 15.10
    Description

    Hello,

    i have to upgrade a FOG 1.2 to the latest version (1.4.x) on ubuntu 15.10

    When i do the ./installfog.sh i got an error, at the end:

    “stopping web service……Failed!”

    I saw the other posts about this problems but i didnt really understand what was the solution. What i understand is that i need php7 but ubuntu15.10 can’t delivery this package, so i’m stuck.

    What’s the solution ? Upgrade to 16.04 ?

    Thanks



  • Thanks, it’s clear now.

    You can mark it as solved, i will export/import on a fresh install when i will have some times



  • @Sunks said in Install problem ubuntu 15.10:

    Is it possible to import fog1.2 database to a fog 1.4.x ?

    It is, fog will update the db to current. you will need to adjust some settings afterwards. Such as ip, and passwords. Details on these are at the bottom of this article: https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG



  • Ok,

    Since i don’t really know how work the downgrade or the upgrade of ubuntu (lost of the data etc…), i think i will just export the database, group, host, ImageManagement and /images and do a fresh install on an other distribution.

    Is it possible to import fog1.2 database to a fog 1.4.x ?

    Thanks


  • Senior Developer

    Yes. Upgrade to 16.04, or even downgrade. PHP that needs to be installed only works with “LTS” versions of Ubuntu. I believe ondrej even supports the most current Ubuntu version when the repo is setup for this, but LTS is where things remain operational .


 

474
Online

5.4k
Users

12.6k
Topics

118.9k
Posts