Deploy imaging tasks but only run them manually?



  • Server
    • FOG Version: 1.4.0
    • OS: Debian Jessie
    Client
    • Service Version: 0.11.12
    • OS: Windows 7
    Description

    We would like to add imaging tasks to a group of clients and then take a walk through the building and reboot into FOG to trigger them.

    However, the moment we deploy an imaging tasks our users are prompted to reboot their machines and we can also observe that our Windows-VMs are forcefully rebooted.

    Is there a possibility to “schedule” imaging tasks but to execute them manually? A kind of silent queue?



  • @Tom-Elliott we already had FOG_TASK_FORCE_REBOOT set but to no effect. I will try disabling it completely.
    Btw. I cannot mark answers of others as correct…



  • This post is deleted!

  • Senior Developer

    Oh, even simpler, Turn off “Task Reboot” on the hosts client/service settings. Or even better, just turn off the “force” reboot portion from FOG Configuration Page->FOG Settings->FOG Client - Task Reboot->FOG_TASK_FORCE_REBOOT

    The hosts won’t magically try to reboot to perform the task in question.



  • @alh the way to do this is how Sebastian said. Set your settings on the host prior, then walk to the box to initiate.

    If you ( the administrator ) tell fog to image via the Web gui, fog of course will obey - and take all the necessary steps to do exactly what you asked.


  • Developer

    @alh Well you can schedule “Delayed Deployment” meaning at a certain time in the future. But this is probably not helping in your situation.

    Why not skip scheduling a job for this entirely? Walk to the client, boot it to the iPXE menu and select “Deploy Image” (or “Quick Image” in older FOG versions), enter web GUI login, select image and walk away…


 

565
Online

5.4k
Users

12.6k
Topics

118.7k
Posts