CentOS 7 Problems



  • followed the steps found here: https://wiki.fogproject.org/wiki/index.php?title=CentOS_7#Installing_CentOS_7

    to install fog on CentOS 7

    some system information:
    0_1497997013405_bandicam 2017-06-20 17-15-35-785.jpg

    0_1497997028135_bandicam 2017-06-20 17-15-54-125.jpg

    The problems are these

    alt text

    no background image on the menu, perhaps there is one and I just haven’t set it. Is there a wiki page on setting this up in CentOS?

    Unable to register the host, claims there is no bzImage

    Thanks in advance



  • @Tom-Elliott said in CentOS 7 Problems:

    The really feels like a double installation almost. Though I don’t know quite how to describe it.

    I’ve fresh installed CentOS with fog at least 5 times now and keep getting the same result
    I attempted a fog installation with Archlinux as well and got this same result.
    by fresh install, I mean wiping the hard drive completely and installing a brand new OS, then installing fog

    @Tom-Elliott said in CentOS 7 Problems:

    Also can you please check FOG Configuration Page->FOG Settings->Web Server->FOG_WEB_ROOT and make sure it’s not set to WEB_ROOT, aka please set to /fog/

    0_1498592218897_bandicam 2017-06-27 14-35-18-036.jpg

    @Tom-Elliott said in CentOS 7 Problems:

    Are you doing any weird redirects? For example FOG is expecting to look to /var/www/html/fog (http://SomeIP/fog/)
    But you have it set to go: http://someIP and it’s passing you to the fog site?

    This is a clean install, I haven’t changed any settings that aren’t stock


  • Senior Developer

    The really feels like a double installation almost. Though I don’t know quite how to describe it.


  • Senior Developer

    Also can you please check FOG Configuration Page->FOG Settings->Web Server->FOG_WEB_ROOT and make sure it’s not set to WEB_ROOT, aka please set to /fog/


  • Senior Developer

    Are you doing any weird redirects? For example FOG is expecting to look to /var/www/html/fog (http://SomeIP/fog/)
    But you have it set to go: http://someIP and it’s passing you to the fog site?



  • @george1421 said in CentOS 7 Problems:

    @Dino_Nerd I’ll ask the same question yet again

    @Dino_Nerd Were you able to complete the steps that Sebastian requested

    @Dino_Nerd Can you access/download the picture (http://192.168.0.15/fog/service/ipxe/bg.png) or the kernel (http://192.168.0.15/fog/service/ipxe/bzImage) from your browser?

    yes and yes.
    Sorry I thought I already answered this but I guess I hadn’t.

    I also reinstalled as BIOS machine instead of UEFI
    My currently running FOG server is CENTOS 7 BIOS. I updated the requested files below


  • Moderator

    @Dino_Nerd I’ll ask the same question yet again

    @Dino_Nerd Were you able to complete the steps that Sebastian requested

    @Dino_Nerd Can you access/download the picture (http://192.168.0.15/fog/service/ipxe/bg.png) or the kernel (http://192.168.0.15/fog/service/ipxe/bzImage) from your browser?



  • @george1421

    Is there a solution to this?
    I’d be very surprised if debian was more stable than a RHEL based OS.



  • @george1421 said in CentOS 7 Problems:

    @Dino_Nerd Were you able to complete the steps that Sebastian requested

    @Dino_Nerd Can you access/download the picture (http://192.168.0.15/fog/service/ipxe/bg.png) or the kernel (http://192.168.0.15/fog/service/ipxe/bzImage) from your browser?

    If you can then the web bits are in place and correct.

    Just to be sure you did set selinux to permissive right?

    yes,

    root@fog:~# getenforce
    Permissive
    root@fog:~#


  • Moderator

    @Dino_Nerd Were you able to complete the steps that Sebastian requested

    @Dino_Nerd Can you access/download the picture (http://192.168.0.15/fog/service/ipxe/bg.png) or the kernel (http://192.168.0.15/fog/service/ipxe/bzImage) from your browser?

    If you can then the web bits are in place and correct.

    Just to be sure you did set selinux to permissive right?



  • @george1421 said in CentOS 7 Problems:

    @Dino_Nerd said in CentOS 7 Problems:

    192.168.0.15

    also save to assume that ^^ is your fog server IP address?

    bump



  • @george1421

    update

    #!ipxe
    set fog-ip 192.168.0.15
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://192.168.0.15/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0xff0000 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap – -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk initrd=memtest.bin iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.0.15/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.0.15:/images/ storageip=192.168.0.15 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.0.15/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.0.15:/images/ storageip=192.168.0.15 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.0.15/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.0.15:/images/ storageip=192.168.0.15 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://192.168.0.15/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot

    0_1498194704855_bandicam 2017-06-22 22-11-04-788.jpg


  • Moderator

    @Dino_Nerd said in CentOS 7 Problems:

    192.168.0.15

    also save to assume that ^^ is your fog server IP address?


  • Developer

    @Dino_Nerd Doesn’t look too bad ;-) Can you access/download the picture (http://192.168.0.15/fog/service/ipxe/bg.png) or the kernel (http://192.168.0.15/fog/service/ipxe/bzImage) from your browser?

    As George said, check the directory on your FOG server: ls -al /var/www/fog/service/ipxe



  • @Sebastian-Roth said in CentOS 7 Problems:

    @Dino_Nerd Please open the following URL in your browser (correct IP for FOG server) and post the full text here: http://192.168.0.x/fog/service/ipxe/boot.php

    #!ipxe
    set fog-ip 192.168.0.15
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://192.168.0.15/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0xff0000 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap – -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk initrd=memtest.bin iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.0.15/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.0.15:/images/ storageip=192.168.0.15 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.0.15/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.0.15:/images/ storageip=192.168.0.15 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=192.168.0.15/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.0.15:/images/ storageip=192.168.0.15 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://192.168.0.15/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot


  • Moderator

    Is this a uef system? If that is the case you may not get the pretty FOG background in the iPXE menu.

    Also did you remember to disable selinux (actually set to permissive)? You should also disable firewalld.

    I agree with Sebastian, call that url with a browser and post it here.

    Also confirm that bzImage exists in /var/www/html/fog/service/ipxedirectory.


  • Developer

    @Dino_Nerd Please open the following URL in your browser (correct IP for FOG server) and post the full text here: http://192.168.0.x/fog/service/ipxe/boot.php


 

423
Online

41.8k
Users

12.3k
Topics

116.0k
Posts