Unable to save settings in FOG configuration



  • Server
    • FOG Version: 1.4
    • OS: Debian 8
    Client
    • Service Version:
    • OS:
    Description

    Hi, I’ve got a very annoying issue. As I tried to make multicast works, I’ve changed some parameters in FOG settings. But now, I can’t save any of the changes in fields, in any section. The page takes time to actualize, the pop up “Settings Successfully stored!” appears but no change is saved !
    In other sections, like host editing, changes are OK.
    I don’t think there’s a “lock” function, so it maybe an apache problem ?
    I’ve run again the 1.4.0 installer and rebooted, no success …
    .
    I guess it’s an apache problem


  • Senior Developer

    Nothing changed in regards to that. I suspect, however, it was related to a ton of “slashes” that made the query larger than it could be to actually perform the update.



  • Well, after upgrading tonight to 1.4.1, I can now save the changes in FOG settings …
    I think this topic can be marked “solved” …



  • I tried to change directly in DB : for example :

    update globalSettings set settingValue='1' where settingKey='FOG_INACTIVITY_TIMEOUT';
    exit;
    

    and it works !

    But still not with the webGUI



  • @Sebastian-Roth No, they’re exactly the same…

    Indeed, the apache logs weren’t displayed in my fog web gui til these days …


  • Developer

    @Flavalf Maybe the log viewer is an issues as well. Please check the apache error logs on your FOG server. See my signature on where to find those…



  • Sadly, no error related to FOG in apache error.log …
    I also checked the mysql DB with

    mysqlcheck -r fog
    

    Everything is OK …


  • Moderator

    Make a change like you posted about then tail the apache error log to see what error its throwing. For debian I think the error log is called error.log and its in the /etc directory somewhere (sorry I’m rhel guy). You can also view the apache error log in the fog configuration -> log viewer area.


Log in to reply
 

437
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.