Could Not Remove Old Partition?



  • Server
    • FOG Version: 1.4
    • OS: Ubuntu 14.04
    Client
    • Service Version:
    • OS:
    Description

    I update my images on VM’s, and recently I have ran into an issue where I get the error message “Could Not Remove Old Parition” when trying to download a few images(pic below). I saw some posts on the forum with the issue, but I didn’t see an answer for something I should try. The images I am trying to download are Win7 images uploaded with partimage not partclone (I believe, as they are not folders on the storage node). Any ideas on how I can troubleshoot this? Let me know what you are thinking when you have time, thanks!

    0_1496184557727_Fog Could not removeJPG.JPG

    Dustin


  • Developer

    @dustindizzle11 Great you got this hacked… :dark_sunglasses: Thanks for letting us know! Marking this solved for now. Let us know if you run into another issue with this.



  • @Sebastian-Roth @Wayne-Workman Just an update, making a folder for the image, switching the type, renaming image file to sys.img.000 and copying partition info into the new folder made the image work.



  • @Sebastian-Roth @Wayne-Workman Sorry for the late reply, I was out of the office until now. They were already set as partimage images. Good catch Sebastian, yes they were Vista images that were actually Windows 7 images (old images that were pre 1.2 when one had to use Vista to upload Win7 images). I changed the image type to Windows 7 from Vista, and since the image file was not a “folder”, I created a folder for the image, moved the image file into the folder and named it “sys.img.000”, and copied partition files from another Win7 image and put them in the folder with it. The image is downloading right now, but I am not positive it will work with me hacking at it haha. Is there a better way to recover those old images or should my process work? (Ill update this if it does or doesn’t work). Thank for the replies, I appreciate the help and feedback!

    Dustin


  • Developer

    @dustindizzle11 Maybe I am wrong but looking at the script code and comparing those to the messages in your screenshot it seems like you’ve set OS ID for this image to 1 (WinXP) or 2 (Win Vista)… but you are talking about Win7 images…



  • Have you tried partimage just to see if the error goes away?


 

528
Online

5.4k
Users

12.6k
Topics

118.9k
Posts