TFTP Server address required



  • Server
    • FOG Version: last
    • OS: Linux
    Client
    • Service Version:
    • OS:
    Description

    Hi,
    when start iPXE Boot process it’s required a server address ;
    if it’s inserted the correct address (192.168.1.140 ) , the boot menu starts correctly.
    I asks how skip this step !!

    Regards! 1_1495636961623_Capture1.JPG 0_1495636961622_Capture2.JPG



  • Perfect !
    I substitute the conf files and replaced “Fog IP Server”,now it works !

    Solved !
    Regards


  • Moderator

    Ok lets start out with some basic information.

    Saying the latest version of fog is not helpful since FOG versions are a moving number. But fog latest is 1.4.0 stable.

    What device is your dhcp server?

    It appears you are using dnsmasq. Are you using this to supplement your dhcp server? If that is the entire content of your ltsp.conf file you may be missing some bits. Try this one

    # Don't function as a DNS server:
    port=0
    
    # Log lots of extra information about DHCP transactions.
    log-dhcp
    
    # Set the root directory for files available via FTP.
    tftp-root=/tftpboot
    
    # The boot filename, Server name, Server Ip Address
    dhcp-boot=undionly.kpxe,,<fog_server_IP>
    
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.
    dhcp-no-override
    
    # inspect the vendor class string and match the text to set the tag
    dhcp-vendorclass=BIOS,PXEClient:Arch:00000
    dhcp-vendorclass=UEFI32,PXEClient:Arch:00006
    dhcp-vendorclass=UEFI,PXEClient:Arch:00007
    dhcp-vendorclass=UEFI64,PXEClient:Arch:00009
    
    # Set the boot file name based on the matching tag from the vendor class (above)
    dhcp-boot=net:UEFI32,i386-efi/ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI,ipxe.efi,,<fog_server_IP>
    dhcp-boot=net:UEFI64,ipxe.efi,,<fog_server_IP>
    
    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1
    
    # The known types are x86PC, PC98, IA64_EFI, Alpha, Arc_x86,
    # Intel_Lean_Client, IA32_EFI, BC_EFI, Xscale_EFI and X86-64_EFI
    # This option is first and will be the default if there is no input from the user.
    pxe-service=X86PC, "Boot to FOG", undionly.kpxe
    pxe-service=X86-64_EFI, "Boot to FOG UEFI", ipxe.efi
    pxe-service=BC_EFI, "Boot to FOG UEFI PXE-BC", ipxe.efi
    
    dhcp-range=<fog_server_ip>,proxy
    

    Don’t forget to replace <fog_server_ip> in the above text with the IP address of your fog server. The tag appears many times.

    ref: https://forums.fogproject.org/topic/8725/compiling-dnsmasq-2-76-if-you-need-uefi-support/6


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.