User cannot join Multicast Session - Invalid Login



  • Server
    • FOG Version: 1.4.0
    • OS: CentOS 7.2.1511
    Client
    • Service Version: n/a
    • OS: n/a
    Description

    This is a problem with just one FOG server. I cannot recreate the problem on another.

    All created users except for the original `admin’ account on this one particular server cannot join a multicast session when manually initiated by the user during a network boot. The response after entering a user name and password is always, invalid login.

    I have verified the client machine itself is not the problem.

    I have deleted all additional user accounts then recreated them and still no go. Only the one remaining account can join a multicast session.

    I tried length of password, length of username, alphabetical sorting differences of username;
    ie: abmin, admin, testuser

    1. network boot machine
    2. Join Multicast Session
    3. enter username and password
    4. receive:
    http...blahblahblah...\boot.php ok
    Invalid login!
    

    The problem presented itself while the server was running 1.4.0-RC14, so I updated it to 1.4.0 and the problem remained.

    Simply deploying an individual image via unicast the credentials are fine.



  • < facepalm >

    Oh geez … okay, ignore everything. There is no problem other than that the switch servicing that bench had been reprogrammed. The ports used had been set to the wrong vlan; a vlan serviced by a FOG server that didn’t have the intended accounts.

    … oy



  • Nothing at all shows up in /var/log/httpd/error_log (CentOS) at the moment of the login failure … just checked it again and nothing populated.


  • Moderator

    @sudburr Looks normal, is there anything in the apache error log when login fails?



  • From FOG Configuration > iPXE Menu Customization > fog.multijoin

    Menu Item:

    fog.multijoin
    

    Description:

    Join Multicast Session
    

    Parameters:

    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    

  • Moderator

    @sudburr I can only assume the multijoin option has been altered, given that it’s the only thing acting up as far as I understand.

    Can you post it here?



  • Everything else ‘looks’ normal.

    The purpose of using this multicast method is to bypass the need to register a machine. I have some 700 systems coming in that will require quick and dirty imaging.

    We know this works on other fog servers; the question is why does this particular feature that involves authentication when joining a session fail to allow anyone but the one account to join a session on this server?


  • Moderator

    What does the multicast (fog.multijoin) boot option look like for you?

    Can you do multicast with a task?


Log in to reply
 

557
Online

39008
Users

10721
Topics

101807
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.