NetBoot problem, new mac..!

  • Server
    • FOG Version: 1.3.5
    • OS: Debian (8.0)
    • Service Version: ¨
    • OS: mac sierra

    Hello all, it’s me again, i have a other problem…
    When I boot on my new mac (model : Z0SC) 27 ", there is a worry … here is a screen:
    alt text

    You should know that with my other mac it works … I tried to reconfigure but nothing works if someone has a solution …!
    Thank you in advance !

  • Moderator

    @Warget I’m glad you have it running now.

    I agree it is not ideal, but until the iPXE folks can create a PXE boot compatible version for your hardware, this is the best we can do from the FOG Project side.

  • Waho ! With the USB key it works, it is not optimal but … a thousand thanks really!
    Fog Developper is realy great !

  • Moderator

    @Warget This should be working!! :-(

    You are getting a dhcp address so the network adapter is working, but FOS can’t reach the FOG server. The error message is a bit misleading but I remember this was an issue because of a bad check.

    Just as an idea, did you remember to change / update the grub.conf file on the usb flash drive. You needed to give the IP address of the fog server so FOS knows how to find the FOG server. It was in the link I provided before: in the section called: The final steps you MUST complete

  • @george1421 said in NetBoot problem, new mac..!:

    @Warget Please confirm that you have the latest kernels and inits on that flash drive. That issue should have been resolved by the developers. What your posted WAS an issue with fog 1.4.0RC8 and before.

    George, realy thank’s for u all reply but it’s not work… seem error ^^!

    I confirm i Use ur current kernels and inits :/

  • Moderator

    @Warget Please confirm that you have the latest kernels and inits on that flash drive. That issue should have been resolved by the developers. What your posted WAS an issue with fog 1.4.0RC8 and before.

    You can download the current kernels and inits from here:

    You can just download them from the above links using a windows computer. Then replace the files on the flash drive with these current ones. You will overwrite what is on the usb boot key.

  • This community is just… waho…!
    @george1421 Thank’s for ur proposition but… I think is not a FOG problem, it’s probably a mac problem… When I use a usb key : alt text

    (My connection is by RJ45, my RJ45 is ok, i try with a other pc)

  • Moderator

    @Warget That is sad that pxe booting is not working.

    We do have an option still for fog (the right answer is to get pxe booting working). If the mac is capable to usb boot into the FOS engine directly. We have to use this method sometimes when the UEFI firmware is faulty and pxe booting fails.

    This method should work but there is one thing you must remember. For imaging, you must schedule a deployment task in the fog server before you usb boot FOS or you will get an error message.

    I will IM you some additional information in a few minutes. Look for the chat icon in the FOG forum tool tray.

  • @george1421 I try to replace, dosen’t work :/
    @Sebastian-Roth Yes I m sure
    @Tom-Elliott Thank’s for ur intervention

  • Senior Developer

    @Sebastian-Roth said in NetBoot problem, new mac..!:

    Thanks a lot for keeping up the discussion in the iPXE forums in March

    I don’t know if anybody filed a bug. Sorry. I’m not as active on the forums for ipxe as I am here so I’ll admit my “follow up” isn’t spot on or anything.

    I still think it’s potentially something that we could fix at least if we knew enough between michael brown and us.

  • Developer

    @Warget Are you sure you have the exact same model and firmware version?

    @Tom-Elliott Thanks a lot for keeping up the discussion in the iPXE forums in March. Do you know if anyone ever filed a bug with Apple??

  • Moderator

    @Warget I was just looking at the picture again, specifically at the build number for iPXE. In the picture the build number is (fdcdc), looking at the rom-o-matic site that version of ipxe is older than the last 20 commits.

    With that in mind it would be interesting to know if an update ipxe kernel might solve this issue. I just looked on the fog github site and those ipxe kernels are a few months old. I’m wondering if the @Senior-Developers could provide the OP a direct link to both ipxe.efi and ipxe7156.efi from FOG 1.4.0RC13 (??)

    @Warget The idea is to replace your existing iPXE kernels for uefi with the newer ones from the latest release of fog. My wish is that the newer kernels will solve your imac problem.

  • That’s exactly it, I conclude that there is no solution currently

    Thank’s for ur all reply !

  • Developer

    @Warget Some Macs are working great, others don’t. Please read though this and this posts! And of course there is a lot of very great information in the iPXE forums as well, see here.

    Possibly you have the exact same Mac models?

  • @george1421 said in NetBoot problem, new mac..!:

    Je pense qu’il y avait un bug dans 1.3.5 où il ne regarderait que net0 et ne testerait aucune autre interface. La mise à niveau vers une version de développement vous donnera également les dernières corrections pour FOG.

    I try to upgarde, but seem error … I think error is on a new mac, i check that, if somebody have a idea o/ ;) !

  • Moderator

    @Warget said in NetBoot problem, new mac..!:

    I have en0, en2 and en3…

    OK that mac has 3 network interfaces then. In your first post I would have expected the iPXE kernel to show the mac address of net0.

    I would like you to update to the latest version of FOG, which is the development release of 1.4.0RC12 using this process:

    I think there was a bug in 1.3.5 where it would only look at net0 and not test any other interfaces. Upgrading to a development release will also give you the newest fixes for FOG.

  • @george1421 said in NetBoot problem, new mac..!:

    d’adaptateurs réseau

    I have en0, en2 and en3…
    (I resolve Can not interpret host as an IPv4 address, but error is same)

  • Moderator

    @Warget I tried to find information on this mac, but failed. How many network adapters are being used in this mac? (the last mac I touched was in 1996).

    Did you change anything to make the error “Can not interpret host as an IPv4 address”?

  • @george1421 said in NetBoot problem, new mac..!:

    Ma réaction initiale est que ce périphérique / condition est lié à l’extension de l’arbre qui ne renvoie pas les données en temps réel. Cela se produit généralement lorsque l’arbre d’extension standard est utilisé. L’utilisation d’un protocole d’arborescence rapide (RSTP, FastSTP et autres prend généralement soin du problème). Un test rapide consiste à placer un commutateur non géré entre l’ordinateur cible et le commutateur de construction et à tester à nouveau. Si la cible reprend le lien, nous avons trouvé le problème.

    Realy thank’s for ur reply
    Yes it’s my first first model of its this type to try pxe^^

    I now have the error: Can not interpret host as an IPv4 address
    When i try to do the sudo bless … i think so you’re right it does not go through the right interface…

    I go try to change this interface^^!

  • Moderator

    @Warget said in NetBoot problem, new mac..!:

    When I boot on my new mac (model : Z0SC)

    When you say this, is this the first model of its type you are trying to pxe boot?

    Does this model have 2 network adapters installed, like a wireless and a ethernet?

    My initial reaction is this device / condition is related to spanning tree not turning forwarding data in time. This usually happens when standard spanning tree is used. Using a fast spanning tree protocol (RSTP, FastSTP, and others usually take care of the issue). A quick test is to place an unmanaged switch between the target computer and the building switch and test again. If the target picks up the link then we found the issue.

    I don’t think that is the issue in your case. This message is saying the link is down, like ipxe is picking the wrong interface to look at.

Log in to reply

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.