Your database connection appears to be invalid.



  • Server VCenter 6.0.0
    • FOG Version: 1.3.5-RC-11
    • OS: Ubuntu
    Client 11.10
    • Service Version:
    • OS: Windows 7 and 10

    So this maybe a VMware question. We are running database on Ubuntu machine on a VM. 600 GB Thick Provision. So we have about 200GB used on the ubuntu Server but the VM says it is at capacity which is giving me this error where database will not start up.

    Any suggestions from others that may have had this problem. Thinking it is a VM issue because the server itself is not full as far as I can see. 200GB used when I do a properties check. So one thing is I deleted a bunch of files yesterday and they seem to be gone and out of trash even. Is there any where that storage maybe taking up or something I am missing. I had another 200GB on there before yesterday. I was working on today and working fine and then all of suddent came to screen database appears invalid. Checked a couple things and seems to point to VM is full.

    One side note related to this when our server is down and pxe is first to boot on the devices any good way to stop looping and restarting without booting into OS. Need to boot in OS and guessing there is a setting in fog or may have to just look at shutting off pxe for a bit. Luckily I have another fog server to point too until this is solved. Thanks for any info or suggestions anyone has!!


  • Moderator

    @grant1842 said in Your database connection appears to be invalid.:

    I had to re run the installer as well as remake my dnsmasq 2.76. … but my dnsmasq reverted back to 2.75 which was causing the boot file to not be received correctly.

    This is only speculation, but I’m guessing that the linux distro you use updated dnsmasq from (2.72 or 2.73) to 2.75, thus overwriting your compiled 2.76. As wayne said the package manager only knows about what it does. Hopefully the next time it happens is when your distribution updates to 2.76 or newer. Then it won’t matter at all.

    On the plus side you were able to discover and fix the problem pretty quickly. So good job there.


  • Moderator

    @grant1842 check your packages list inside of /opt/fog/.fogsettings and if you see dnsmasq in there, remove it. Also, if you follow @george1421’s instructions on building dnsmasq - that work gets overwritten if you used your package manager (apt-get or yum or dnf or pacman) to install dnsmasq, because the package manager will see that it’s managing dnsmasq and will update it when a newer version than what the package manager installed becomes available, overwriting your custom build. This is because your package manager is not aware that you replaced the binary with a custom one. All it knows is what it’s done itself.

    Just things to be aware of.



  • I had to re run the installer as well as remake my dnsmasq 2.76. For some reason after the server was restarted I also had the invalid database message but my dnsmasq reverted back to 2.75 which was causing the boot file to not be received correctly.



  • Thank You!! Solved! Have a great weekend!


  • Moderator

    @bmick10 use same instructions without the git commands. The git commands update the install files



  • Sorry for this question I am not expert on commands in Ubuntu and want to make sure I am doing right. Best way to rerun installer. I have just been running the updater which would give me latest version but want to just stay at this version I have. 1.3.5r11. So instead of running below best way to rerun installer without updating. Thanks

    cd /root/fogproject
    git checkout dev-branch
    git pull
    cd bin
    ./installfog.sh


  • Senior Developer

    @bmick10 Please rerun the installer. This has been a common problem overnight apparently.



  • 0_1493422029101_upload-075d6a27-7e90-4be9-ab4d-c42a688d5a96


  • Moderator

    @bmick10 from the defective FOG server linux console prompt key in df -h and post the results here.

    Hint: if you connect to the fog server using putty you can copy and paste easier to the forum than from the fog server itself.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.