@NateUH Yes it is supposed to auto-start on bootup of your FOG server. Please run systemctl is-enabled FOGMulticastManager.service to see if it’s enabled on bootup. If you get disabled there must have been an issue when running the installer. You might run systemctl enable FOGMulticastManager.service or re-run the installer to do this for you. But if it’s enabled already then you might be running into a startup dependency issue in FOG 1.5.7 which we have fixed lately. Ask here if you need more details on this.