I ended up testing on another (4th) machine and that worked too but this ASUS still refused to play ball.

However, finally solved it!! (I couldn’t work out how to change the title, if an admin wants to mark it solved, please go for it)

It ends up the problem seemed to be that my Fog server (within TFTP) was handing out the wrong DNS server IP (DHCP was handing out the right one, just it was wrong in the Fog settings). I’m still not sure why or how that was the problem (my FOG storage server was set using IP not hostname) and it was strange that all the other machines worked ok (just not this one). But that seemed to fix it, so happy days! 🙂