New forums, can edit posts now ;). Have you tried specifying the printer IP to see if that helps?
Posts
-
RE: Adding printer via FOGposted in FOG Problems
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
ok. query the users table in the fog database in mysql and post the contents.
[CODE]
mysql -u root -ppassword fog
mysql>select uName from users;
[/CODE]That should list all logins available to the web interfaces.
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
That doesn’t look right. The MYSQL_USERNAME shout be root on the master fog server. the MYSQL_PASSWORD should be whatever you use when connecting using “mysql -u root -p” from the command line.
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
ok. now make sure the mysql password is set properly in the /var/www/fog/commons/config.php file.
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
I get the “undefined index” errors in my apache log also. They do not keep FOG from working.
Also, why did you quite your own post with the entire log file over again?
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
I don’t see any errors that would indicate a php failure during the authentication check.
Don’t get confused between a system user and a FOG user and a MySQL user.
Is your MySQL root password blank?
Try to login to mysql as root without a password:
[CODE]mysql -u root[/CODE]
Do you get in or do you get an error?
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
I don’t IRC, but I do actively monitor the forums all day long (Central time, US).
-
RE: Multicast very slowposted in FOG Problems
[quote=“chad-bisd, post: 5248, member: 18”]Are the similar machines at another location using this same FOG server? I’m trying to track down the differences between the two groups and why the speeds would be so different.
Yes, FOG is alive and kicking.[/quote]
-
RE: Bzimage small terminalposted in FOG Problems
Probably the video drivers. If you use xconfig, you can search the config for specific items (I think).
-
RE: Adding printer via FOGposted in FOG Problems
use code tags when posting log files or terminal output so the smilies don’t get in the way.
I’m going to assume you’ve already been through: [url]http://www.fogproject.org/wiki/index.php/Managing_FOG#Printers[/url] and made sure all the settings are correct for the printer you are trying to deploy.
Why brand/model/driver versions are you trying to use?
-
RE: Changing IP Addressposted in FOG Problems
You just need to search the wiki. There is an article for changing the IP address of the FOG server that shows all the places you need to edit. WIKI link in my signature. Search for keyword “address” since “ip” is too short to return any results.
-
RE: Network with Static Configurationposted in Windows Problems
In the FOG web interface, go to Storage Management, All Storage Nodes, and click on the DefaultMember. Make sure the Management Password is set to the same password as the fog user in the OS, which appears to be “lounge” based on your config.php file you posted.
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
When posting terminal output or log files, always put them inside CODE tags so they stand out and are not interpreted into smilies by the bb software.
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
The instructions were not for creating a user named fog, but for resetting the password.
Did you check your apache logs for related errors. (/var/log/apache2/errors.log)
-
RE: Fog replicator process quits after remote image transferposted in FOG Problems
Ok. I’ve done some mods. The files actually transfer to all storage nodes in the storage group at the same time. The tricky part is the output to the log file. I can easily start multiple file transfers to the storage nodes, but I can only monitor 1 at a time. So although you see in the log file that all the storage nodes started syncing, you won’t get the results of the rest of the storage nodes until the first one finishes all it’s transfers.
If you had 5 nodes, you’ll see all of them start, then the progress for each file on node1 until node 1 has finished all it’s files, then the status for node2 until it’s finished, so forth and so on. The transfers are all happening at the same time, but are reported to the log file only after each node finishes.
[LIST=1]
[]Backup /opt/fog/service/FOGImageReplicator/FOGImageReplicator
[]Save the attached file
[]Unzip it
[]Copy the FOGImageReplicator file to /opt/fog/service/FOGImageReplicator/FOGImageReplicator, overwriting the existing file.
[]Restart the FOGImageReplicator daemon using: [CODE]sudo /etc/init.d/FOGImageReplicator restart[/CODE]
[]Monitor the log file: [CODE]sudo tail -f /opt/fog/log/fogreplicator.log[/CODE]
[*]Monitor the /images/ folder on your storage nodes to make sure the files are getting there.
[/LIST]
If you want to create a test dummy file so you have something to replicate without replicating a huge image, you can use:
[CODE]
cd /images
sudo dd if=/dev/zero of=/images/testfile100mb count=1024 bs=102400
[/CODE]
This creates an approx 100MB file in the /images/ folder named testfile100mb.
Restart the FOGImageReplicator daemon using step 5 from above and watch the log file using step 6.
Have an SSH session open to your storage nodes and you can watch the files being created on each node in parallel. I just “ls -l” on the /images/ directory on the storage nodes to see if the files are being created. If you are quick and have each storage node open, you can watch them all get the file.
[B]All the normal disclaimers apply. No warranties, assurances, or guarantees this will work or not work, help or harm your systems.[/B] I can reasonably say it works based on about 4 hours of coding and testing using 1 main server and 2 storage nodes in VirtualBox and syncing 2 files of 100MB and 1GB respectively.[url=“/_imported_xf_attachments/0/148_FOGImageReplicator.ParallelFTP.zip?:”]FOGImageReplicator.ParallelFTP.zip[/url]
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
If it’s a password issue. Try: [url]http://www.fogproject.org/wiki/index.php/Reset_WebUI_FOG_password[/url]
If that doesn’t help, check your syslog or apache log for errors that might help us track down why you can’t logon to the webUI.
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
What is the error on your main fog server’s webUI? Do you get a login screen or just a blank? Does it not let you log in as fog or any other users you have created in FOG?
-
RE: Multicast very slowposted in FOG Problems
If you have a support contract with Cisco, you might be able to open a ticket to help resolve this issue, or at least troubleshoot it from a switch/router point of view.
-
RE: Failed to connect to database server, will try again in next iteration.posted in FOG Problems
Make sure you are trying to bring up the webUI on the main/normal FOG server. I don’t think the webUI will bring up anything on the storage node.
-
RE: New Fog build not deploying imagesposted in FOG Problems
FOG images are multi-part. You have the actual image files and folders under /images/ and then you have the meta-data that defines them to FOG, which is in the database and displayed in the WebUI.
What you need to do is export the data from the existing fog server database and import into the new one. If you just want the image definitions, then just worry about the images table. If you want all the host information, then you need to export the images/hosts, and possibly other tables.