Upgrading from FOG 7498



  • Server
    • FOG Version: (Trunk?) 7498
    • OS: Ubuntu 14.04
    Description

    I was looking to update my FOG Server since I was having trouble imaging some of the newer Lenovo laptops like the E575. Usually updating FOG has fixed it for me in the past.

    The problem this time is I can’t seem to get it to upgrade right using the Trunk GIT method. I installed GIT and followed the directions but it said something was already in root/fogproject/ (makes sense since it’s not a new install), and then I tried the upgrade instructions but it said this was not a GIT repository for this folder or no GIT was found… something like that. I figured this might be because I don’t remember using GIT when I upgraded last time.

    I’m not sure where to go from here. It’s probably been close to a year or more since my last upgrade. It’s possible that this is so old I need to do a new install and migrate? Not sure.

    Thanks!


  • Moderator

    @mlerch so just a hint here: the fog settings are kept in /opt/fog/.fogsettings file. That is where fog knows what the user account and password should be.



  • That’s a dang good guess! I just used Fog as the user since I wanted to keep it all the same. I’ll create a new one then. Probably explains some other problems I’ve had haha.

    Thanks!


  • Moderator

    @mlerch said in Upgrading from FOG 7498:

    Any time I upgrade FOG it always changes my user password on Ubuntu and doesn’t allow me to login.

    If you are using a linux account called fog don’t use it. That is reserved for internal fog use only. Make a new user account for managing the system. (this is just a guess reading the tea leaves).



  • Got it all setup and it’s working great! It’s even imaging the new Lenovo laptop no prob like I thought it would! Thanks for the help guys.

    also one weird quirk. Any time I upgrade FOG it always changes my user password on Ubuntu and doesn’t allow me to login. I have no idea what it changes it to. I have to go through the adv startup for Ubuntu to change the password back. Is there any way to keep that from happening?


  • Moderator

    Sounds like you originally installed with SVN (guessing) or unzipped it to /root/fogproject

    Either way, moving it or deleting it will allow you to use git checkout no problem.


  • Moderator

    just rename the /opt/fogproject folder to /opt/fogproject.old and then run the git command again. It will rebuild the entire directory.

    sudo -i
    git clone https://github.com/FOGProject/fogproject.git /opt/fogproject
    cd /opt/fogproject
    git checkout dev-branch
    cd bin
    ./installfog.sh
    

Log in to reply
 

457
Online

38959
Users

10706
Topics

101583
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.