HP EliteDesk 705 G2 MINI

  • We have received a pallet of these PCs and are unable to get them to take an image.
    I have narrowed the problem down to the Broadcom BCM5762 GbE NIC which uses the tg3 driver.

    This throws up “tg3_stop_block timed out” errors when trying to access the network to mount the images share or even take an inventory.

    I have tried to update the kernel to 4.11-rc8 with the same error.
    I am currently running FOG 1.4.0-RC-8

    Our workaround is to image the disks in a spare PC pull the power on the end of image re-boot and put the disks back in (taking care not to break the ribbon cable in the process).

    Any ideas on how to get these Broadcom NICs to work with FOG, or indeed Linux?

  • Moderator

    @Andrew-ASPH I’m glad you guys found a way to work around this. That network adapter must not have a very good network speed negotiation protocol.

    I can also imaging that imaging at 100Mb/s (12.5MB/s) would not be much fun. On a 1GbE network we typically see about 6GB per minute (~100 MB/s) transfer rates, with a 15GB image taking about 4 minutes.

  • @joaoguedes
    I have tested as well, and these PCs only image when connected to a gigabit port, No all I have to do is persuade the network manager to let me have gigabit ports for imaging rarther than the standard 100Mb he restricts everyone to.

  • I did another test, I had already changed the switch port where my server is connected to 100Mbps and had left the port where my machine is in Auto [1000], every things perfect. When I changed the machine port to a fixed value of 100Mbps, the problem began to occur in the port that previously worked.

    I’m not sure, but I think I’ve already tried to create an image on another machine model on a 100Mbps port and the problem did not occur. Is this a problem on HP’s PC, which only accepts network boot at 1000Mbps?

  • I had the same problem with HP EliteDesk 705 G2 Mini and the G3 Mini too.
    I figured out a way to clone the machines, but I don’t know exactly what the problem is, not even the solution.
    When I used a new network cable connected to a 1000Mbps port, the cloning process goes perfectly, however when I use a 100Mbps port on the same switch, the error always occurs.
    I had to use my single gigabit port to clone all machines, 1-by-1.
    I reduced the server’s port speed from 1000Mbps to 100Mbps, forcing it to work at 100Mbps, but the gigabit port is the only one that keeps running.

  • @george1421
    That is correct, It is looking like a Kernel bug, so FOG will have to await a fix in a future kernel. I’m not sure who in teh Kernel devs would be best to talk to about getting the tg3 driver fixed however.

  • Moderator

    @Andrew-ASPH Just to recap where we are at.

    The current linux kernel that FOS uses doesn’t support these nics.

    A Commercial (so to speak) Linux distribution also can not init these nics.

    The workstation has been fully patch with firmware updates.

  • @Tom-Elliott
    I have tried 3 of the 50Pcs we have and 2 have registered and not imaged, 1 has failed to register.

    I have updated one to the latest BIOS using the built-in updater

    It all appears to work fine under Windows and our image will work with it, and install the drivers once the PC has it on the disk.

    I found this bug report on kernel.org

    It looks like the bug fixed in 2009 has kicked in again.
    I shall register there and see what I can do to get it fixed.

  • Senior Developer

    I might also suggest updating the BIOS in the case there’s a problem with the nic:


    These are just the nic drivers, if I’m reading into this correctly.

    ANd full software driver information:

  • Senior Developer

    This is on ANY system with the same nic?

    It seems the system you’re testing might have a bad nic, but this is just a guess.

  • @george1421
    I can image using other models without a problem (and my colleague has been to make sure that the various images work with the new model by using a spare PC to write the image to disk to put in a 705 DM) I can pint the FOG server from the command line before the “tg3_stop_block” errors.
    I have tried mounting the NFS share, which sometimes completes but I am then unable to list any of the contents.
    after the “tg3_stop_block” errors the IP is shown as still associated, but the NIC is down and unresponsive.
    I think it is a kernel bug and will try and find out who to send any error messages to there. But until a fix or less awkward workaround is found I think these PCs are not compatible with FOG.

  • Moderator

    @Andrew-ASPH I’m not saying the issues are related, but I’ve see a number of systems not connecting to the nfs share today. I don’t know if its related to 1.4.0RC8 or something else.

    But if we could get you to boot back into the debug shell of fos.

    You can ping the fog server I might suppose.

    Can you map to the fog server from the target computer running fos in debug mode?

    mkdir /mnt
    mount -t nfs <fog_server_ip>:/images/dev /mnt
    ls -la /mnt
    umount /mnt


  • @Andrew-ASPH
    running the fog deploy debug mode on the one PC I managed to get to register, it always crashes out attempting to mount or use the NFS images share

  • Moderator

    @Andrew-ASPH Based on your last picture, OK what’s your problem? FOS has an IP address.

  • Moderator

    @Andrew-ASPH It sounds like you have a bleeding edge nic card in that device.

    Would I would do next is check the broadcom web site to see if there is a specific linux driver available for that system. If so, you “might” be able to talk the developers into integrating that nic driver into the FOS engine.

  • @Wayne-Workman
    I have install Kubuntu on it from a USB stick, the Intel WiFI works fine, the Broadcom NIC is recognized and has the same error
    from dmesg

      7.969752] tg3 0000:01:00.0 eno1: Link is up at 100 Mbps, full duplex
    [    7.969785] tg3 0000:01:00.0 eno1: Flow control is off for TX and off for RX
    [    7.969789] tg3 0000:01:00.0 eno1: EEE is disabled
     23.114701] ------------[ cut here ]------------
    [   23.114713] WARNING: CPU: 3 PID: 0 at /build/linux-2NWldV/linux-4.10.0/net/sched/sch_generic.c:316 dev_watchdog+0x22c/0x230
    [   23.114714] NETDEV WATCHDOG: eno1 (tg3): transmit queue 0 timed out
    [   23.114715] Modules linked in: ccm rfcomm cmac bnep nls_iso8859_1 hp_wmi sparse_keymap edac_mce_amd edac_core kvm arc4 irqbypass crct10dif_pclmul snd_hda_codec_realtek snd_hda_codec_generic crc32_pclmul snd_hda_codec_hdmi ghash_clmulni_intel snd_hda_intel pcbc snd_hda_codec snd_hda_core snd_hwdep aesni_intel aes_x86_64 crypto_simd snd_pcm glue_helper cryptd snd_seq_midi iwlmvm snd_seq_midi_event mac80211 snd_rawmidi input_leds k10temp fam15h_power snd_seq btusb btrtl btbcm btintel snd_seq_device snd_timer i2c_piix4 bluetooth iwlwifi snd cfg80211 soundcore shpchp mac_hid parport_pc ppdev lp parport ip_tables x_tables autofs4 hid_generic usbhid hid amdkfd amd_iommu_v2 amdgpu i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect sysimgblt fb_sys_fops ahci tg3 drm libahci ptp pps_core wmi fjes video
    [   23.114763] CPU: 3 PID: 0 Comm: swapper/3 Not tainted 4.10.0-20-generic #22-Ubuntu
    [   23.114764] Hardware name: HP HP EliteDesk 705 G2 MINI/805B, BIOS N26 Ver. 02.12 03/27/2017
    23.114827] tg3 0000:01:00.0 eno1: transmit timed out, resetting
    [   25.845096] tg3 0000:01:00.0 eno1: 0x00000000: 0x168714e4, 0x00100506, 0x02000010, 0x00000000 
    25.846010] tg3 0000:01:00.0 eno1: 0: Host status block [00000001:00000034:(0000:004f:0000):(0000:0038)]
    [   25.846014] tg3 0000:01:00.0 eno1: 0: NAPI info [00000034:00000034:(0043:0038:01ff):0000:(011b:0000:0000:0000)]
    [   25.846017] tg3 0000:01:00.0 eno1: 1: Host status block [00000001:0000002b:(0000:0000:0000):(002a:0000)]
    [   25.846020] tg3 0000:01:00.0 eno1: 1: NAPI info [0000002b:0000002b:(0000:0000:01ff):002a:(002a:002a:0000:0000)]
    [   25.846023] tg3 0000:01:00.0 eno1: 2: Host status block [00000001:00000018:(0017:0000:0000):(0000:0000)]
    [   25.846027] tg3 0000:01:00.0 eno1: 2: NAPI info [00000018:00000018:(0000:0000:01ff):0017:(0017:0017:0000:0000)]
    [   25.846029] tg3 0000:01:00.0 eno1: 3: Host status block [00000001:0000000a:(0000:0000:0000):(0000:0000)]
    [   25.846032] tg3 0000:01:00.0 eno1: 3: NAPI info [0000000a:0000000a:(0000:0000:01ff):0009:(0009:0009:0000:0000)]
    [   25.846035] tg3 0000:01:00.0 eno1: 4: Host status block [00000001:0000000a:(0000:0000:0009):(0000:0000)]
    [   25.846038] tg3 0000:01:00.0 eno1: 4: NAPI info [0000000a:0000000a:(0000:0000:01ff):0009:(0009:0009:0000:0000)]
    [   25.970163] tg3 0000:01:00.0: tg3_stop_block timed out, ofs=4c00 enable_bit=2
    [   26.135142] tg3 0000:01:00.0 eno1: Link is down
    :~$ uname -a
    Linux PC38858 4.10.0-20-generic #22-Ubuntu SMP Thu Apr 20 09:22:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

    I can provide the full back trace if required

Log in to reply





Looks like your connection to FOG Project was lost, please wait while we try to reconnect.