PXE Downloads image but does not boot to it (Solved)



  • When I go to image a computer, pxe starts on ipv4, then it claims to download the image, but promptly goes on to try pxe ipv6 and never boots to the image it just downloaded.
    https://www.mediafire.com/folder/5fm19diihizsi/PXE_problems


  • Moderator

    @jamcdonald120 Well what I wanted a bit of clarity on is this. Tom saw as well as I saw in your files that you were / are sending the wrong boot file to this computer.

    There are two types of boot files and its important to configure the right one to be sent to the right type of hardware.

    There is the undionly.kpxe boot file, that is for bios (legacy) computers. And there is ipxe.efi that is for uefi based computers (as in the one from the pictures). If you have a mix of computers (bios and uefi) in your environment you will have some difficultly with imaging. There are ways to work around this but knowing what you are deploying to is the first step.



  • Thank you @Tom-Elliott I reordered the bios boot order and now it works fine
    @george1421 I figured it our but 1. Latest Trunk, 2. https://pcpartpicker.com/list/bD3wpb 3. new OS/fog install, but I have use this machine before, 4. Yes, 5. Not sure, IT did that based on your integrating fog with existing network article


  • Moderator

    OK lets get a bit more background infromation from you first. I have an idea of the problem, but lets get the details.

    1. What version of FOG are you using.
    2. What hardware are you trying to pxe boot?
    3. Is this fog server new or have you image with it before?
    4. Have you imaged this type of target computer before?
    5. What precisely do you have configured for dhcp option 66 and 67?

    Lets start with that.


  • Senior Developer

    Based on the first picture I looked at, you are booting a UEFI Stack over undionly.kpxe. This will not work.

    You need to use ipxe.efi for EFI network booting.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.