Downgrade from 1.4 RC 4 to 1.3.5



  • Server
    • FOG Version: 1.4 RC 4
    • OS: Linux Mint
    Client
    • Service Version: v0.11.11
    • OS: Win7
    Description

    After running the upgrade and getting 1.4 RC 4 the URL interface is blank. Is it possible to downgrade back to 1.3.5? If not how can I save the images and settings and reinstall?



  • Update 1.4 RC 5 fixed the issue. Thanks for everyones help!


  • Moderator

    @greenguy27 Can you call up the fog url and then tail the log file? There isn’t anything remarkable in the error log.

    One other thing that comes to mind, did you have url redirection turned on to bounce you from http://<fog_ip> to http://<fog_ip>/fog ? FOG 1.4.x seems to break this if you had it in place.


  • Senior Developer

    There’s so many similar issues.



  • using: tail -n 100 /var/log/apache2/error.log

    [Thu Apr 13 07:35:03.760051 2017] [core:notice] [pid 1339] AH00094: Command line: ‘/usr/sbin/apache2’
    [Thu Apr 13 11:14:19.223925 2017] [mpm_prefork:notice] [pid 1339] AH00169: caught SIGTERM, shutting down
    [Thu Apr 13 11:15:20.772429 2017] [mpm_prefork:notice] [pid 1094] AH00163: Apache/2.4.25 (Ubuntu) OpenSSL/1.0.2k configured – resuming normal operations
    [Thu Apr 13 11:15:20.955506 2017] [core:notice] [pid 1094] AH00094: Command line: ‘/usr/sbin/apache2’
    [Thu Apr 13 11:28:19.026076 2017] [mpm_prefork:notice] [pid 1094] AH00169: caught SIGTERM, shutting down
    [Thu Apr 13 11:28:32.070103 2017] [mpm_prefork:notice] [pid 8402] AH00163: Apache/2.4.25 (Ubuntu) OpenSSL/1.0.2k configured – resuming normal operations
    [Thu Apr 13 11:28:32.070159 2017] [core:notice] [pid 8402] AH00094: Command line: '/usr/sbin/apache2’
    rossc5@FOGimaging:~$
    rossc5@FOGimaging:~$ tail -n 100 /var/log/apache2/error.log
    [Thu Apr 13 07:35:03.760024 2017] [mpm_prefork:notice] [pid 1339] AH00163: Apache/2.4.25 (Ubuntu) OpenSSL/1.0.2k configured – resuming normal operations
    [Thu Apr 13 07:35:03.760051 2017] [core:notice] [pid 1339] AH00094: Command line: ‘/usr/sbin/apache2’
    [Thu Apr 13 11:14:19.223925 2017] [mpm_prefork:notice] [pid 1339] AH00169: caught SIGTERM, shutting down
    [Thu Apr 13 11:15:20.772429 2017] [mpm_prefork:notice] [pid 1094] AH00163: Apache/2.4.25 (Ubuntu) OpenSSL/1.0.2k configured – resuming normal operations
    [Thu Apr 13 11:15:20.955506 2017] [core:notice] [pid 1094] AH00094: Command line: ‘/usr/sbin/apache2’
    [Thu Apr 13 11:28:19.026076 2017] [mpm_prefork:notice] [pid 1094] AH00169: caught SIGTERM, shutting down
    [Thu Apr 13 11:28:32.070103 2017] [mpm_prefork:notice] [pid 8402] AH00163: Apache/2.4.25 (Ubuntu) OpenSSL/1.0.2k configured – resuming normal operations
    [Thu Apr 13 11:28:32.070159 2017] [core:notice] [pid 8402] AH00094: Command line: ‘/usr/sbin/apache2’


  • Moderator

    @greenguy27 lets see what apache is complaining about before rolling back.

    Please check the apache error.log file, just tail the end of the file and report what you find.


Log in to reply
 

379
Online

38981
Users

10712
Topics

101676
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.