FOG pxe menu not displayed



  • Server
    • FOG Version: 1.3.5
    • OS: CentOS 7 Minimal
    Client
    • Service Version: N/A
    • OS: N/A
    Description

    Hello! I am running into some trouble with finalizing my Fog server. I started by doing a dnsmasq proxy dhcp setup but got access to the DHCP server and made changes to include Option 66 and Option 67. Since that change I have not been able to see the FOG menu display when pxe booting. At the moment I get the following error then I have to select i to enter pxe command and enter autoboot for the image to be captured. What am I missing? Sorry ahead of time for the question if it is obvious. I’m really dead on ideas.

    http://imgur.com/cJBWKPQ

    http://imgur.com/rmPmeQC



  • You were absolutely correct. The Cisco switch was running regular Spanning tree. It has been modified to use the fast spanning tree and it worked like a charm!


  • Moderator

    @rmorris Just some background information.

    As FOS boots (the customized linux that runs on the target computer), it will wink (or momentarily turn off and back on) the network link light as each kernel takes over control of the network port on the target computer.

    You will get a wink when the PXE Rom turns over control to iPXE
    You will also get a network wink when iPXE turns over control to FOS

    The issue with spanning tree is that it will pause the network data on a port for 27 seconds after the link like turns on. FOS boots so fast, by the time standard spanning tree starts forwarding data (>27 seconds), FOS has already given up trying to boot. The fast spanning tree modes start forwarding data right away then listen for the bpdu announcements. That’s optimistic verses pessimistic forwarding.



  • Okay I’ll test and reply back to this with the results. It may take a day or two though due to the networking team having to get involved.


  • Moderator

    Can you insert a dumb switch between the target computer and the building switch and test it againg.

    When we see this issue, it is typically when spanning tree is turned on (a good thing) but the building switch isn’t using one of the fast spanning tree protocols (RSTP, MSTP, FastSTP, or what ever your switch mfg calls it). By putting a dumb (unmanaged) switch between target computer and the building switch that will keep the building switch port from dropping while FOS is booting. Understand this is only a quick test to tell us if you need to have your network group look into the spanning tree settings on your switches.


Log in to reply
 

483
Online

39183
Users

10831
Topics

103117
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.