Please enter TFTP-Server



  • Hi Guys, im having the same issues as the referred post. Getting the “Please enter TFTP-Server:”-Prompt from time to time on different computers, without seeing any typical behavior. I just looked at the network by capturing packets with tcpdump to ensure that there isn’t any rouge dhcp-server or service on this network.

    I also provide you my .pcap-File i recorded,0_1491547288376_output.pcap, like mentioned from ‘george1421’ in the referred post.

    Can anyone say how is it possible that this “Please enter TFTP-Server”-Prompt shows up? Im really confused about the situation because i dont know where to look for the problem now.

    Re: FOG 1.3.0 - SVN 6050 - “Please enter tftp server:”##### Server

    • FOG Version: 1.3.5
    • OS: Ubuntu 16.04
    Description

    Re: FOG 1.3.0 - SVN 6050 - “Please enter tftp server:”


  • Moderator

    Looking at your pcap file I would say you have 2 dhcp servers on your network (not a good option).

    One is 192.168.5.1 and one is 192.168.5.200.

    192.168.5.1 appears to be a router that is passing out an IP address but no pxe boot information. 192.168.5.1 is passing out a client address of 192.168.5.80 to the client.

    192.168.5.200 appears to be (maybe) a fog server running either dnsmasq or isc-dhcp server (probably). 192.168.5.200 is passing out a client address of 192.168.5.10 to the client. 192.168.5.200 is sending out a boot file of undionly.kkpxe with a next server of 192.168.5.200.

    This seems to be confusing the clients because one time they accept the IP address of the router and sometimes they accept the ip address from fog (which is not providing enough information, but does provide pxe booting information).

    Course of action:

    1. Disable the isc dhcp server on the FOG server.
    2. Install DNSMASQ to provide the pxe boot information without providing a ip address to the client.

Log in to reply
 

394
Online

38744
Users

10565
Topics

100021
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.