Dell Optiplex 7010



  • My 0.32 fog server seems to have issue with this new Dell 7010. I would like to know if anyone here can help me how to get this resolve? Thanks.


  • Developer

    Thanks heimer14!

    That link will definitely be useful!



  • I know this is an old Post, but I had the same issue with the HP 6305’s and their unfriendlyness with fog.
    After wasting a week on research and different kernels, rolling back bios etc, here is what I found to work:

    Ubuntu 12.04 with fog .32, running kernel 3.8.8
    had to reformat the hdd with a NON hp Windows 7 disk and once the computer came up, I rebooted from the non HP Disk and followed these instructions:

    [url]http://superuser.com/questions/642420/tools-to-convert-gpt-to-mbr-without-access-to-an-os[/url]

    I did that for the initial image, or golden image as some call it, and after that every computer has imaged perfectly, and very quickly.

    Hope that helps!



  • Hi,

    if the OS was installed via UEFI respective GPT is used then it’s only possible to image as raw and with most hw it’s not possible to boot via PXE (legacy) if any UEFI Boot device is enabled.

    I have that problem with a HP 6305 where Windows 7 was preinstalled, this was done by UEFI using GPT, it is not possible in bios to have the network card enabled for legacy pxe booting while it’s needed to have an uefi boot device because windows will only boot then.

    I contacted the HP Support and at the end they say the TFTP Server has to support UEFI PXE.

    Greetz X23



  • Never had a problem imaging Dell 7010 / 710 or 790. After preparing the “master” and uploading the image to FOG (using single NTFS, resizable for XP and multiple, non-resizable for Windows 7), I always schedule a “Quick Wipe” to the computers to be imaged, followed by a “Deploy”. So far I’ve imaged 20+ 7010 without a hitch.

    Maybe the “Quick Wipe” just sets the partition to be compatible with FOG? I don’t know, but never had any problems. Been using the 3.3.3 and 3.6.9 kernels, and did not find any issues.



  • You sir are awesome :) That worked perfectly! Just imaged about a dozen 7010’s!!! Thank you so much!!!



  • [quote=“michieru, post: 11292, member: 3086”]The fix is to boot Gparted and partition the HD from GPT to MSDOS. Set the BIOS to legacy and FOG will read the partition table properly. Took me several tries and pains but I have deployed 6 new machines with a fresh 7010 image.[/quote]

    I will give that a try right now! :) thank you for your help!



  • [quote=“fogfan, post: 11286, member: 3298”]My EXACT same situation. Other images work great. Same EXACT problem as me.[/quote]

    The fix is to boot Gparted and partition the HD from GPT to MSDOS. Set the BIOS to legacy and FOG will read the partition table properly. Took me several tries and pains but I have deployed 6 new machines with a fresh 7010 image.



  • [quote=“michieru, post: 11258, member: 3086”]For the Optiplex 7010 I have attempted as well with no luck for the past two days with legacy BIOS. I tried kernal 3.6.9 and 3.3.3 without any luck. The issue appears to be when it’s about the transfer it shows that it cannot move the file from /images/dev to /images and even after I do chown -R fog.root /images I have no issues with other images but this one.

    Although I do believe something might have got jacked on FOG I also do believe it’s not properly reading the MBR after my first attempt at uploading.

    @Kevin - If you can provide a guide or the steps you have taken to get the image on the machine that will be greatly appreciated.

    -michieru[/quote]

    My EXACT same situation. Other images work great. Same EXACT problem as me.



  • For the Optiplex 7010 I have attempted as well with no luck for the past two days with legacy BIOS. I tried kernal 3.6.9 and 3.3.3 without any luck. The issue appears to be when it’s about the transfer it shows that it cannot move the file from /images/dev to /images and even after I do chown -R fog.root /images I have no issues with other images but this one.

    Although I do believe something might have got jacked on FOG I also do believe it’s not properly reading the MBR after my first attempt at uploading.

    @Kevin - If you can provide a guide or the steps you have taken to get the image on the machine that will be greatly appreciated.

    -michieru



  • I don’t have any problem with OptiPlex 760, 390, 790, 3010 and 7010.

    Maybe u must update kernel (via FOG)


  • group:cid:13:privileges:mods:members

    If you guys were to post where FOG is failing, we would be more than willing to help you through the issues you are experiencing.



  • [quote=“fogfan, post: 10419, member: 3298”]I’ve got about 20+ 7010’s to image as well I can just can’t seem to get them to work. Been at it for about 3 day now. I updated them to the latest BIOS and re-installed FOG about 6 times lol

    Ubuntu 10.04
    FOG .32
    3.6.9 Kernel

    What BIOS settings, version, etc. and server settings did you use depdesu? I would love to get these working like you! Feel like I’m losing my mind lol[/quote]

    I stopped using the newest kernel and went down to the latest KS (Kitchen sink) one. I feel for you spending 3 days trying to get fog to work, I’ve been there. I have to install over a hundred of these machines during spring break and will probably just end up using clonezilla again to save time and heartache.


  • group:cid:13:privileges:mods:members

    We order all SFF machines, only for special applications do we order towers or USFFs. Our SFF machines have regular HDD’s, but our USFF all have SSD’s. However, I can say that our E6430’s have SSD’s in them, and with the new kernel, we’ve had zero problems with imaging.



  • Thanks for the feedback. I might be getting some of the sff and the usff 7010s. I’m hoping one image will manage for both. I’m glad you mentioned the ssd issue – something to consider. Perhaps I’ll just order one and test it out before I commit.

    Cheers, astrouga


  • group:cid:13:privileges:mods:members

    We’ve had no problems with the 7010’s running kernel 3.6.9. We do have some 7010 USFF, but I personally haven’t tried imaging one of those yet. When we got them, we put our own custom installs on them. Ours also have SSD’s in them, so that could make a difference as well come imaging time. I might be able to snatch another one in a day or two to give it a quick test to check and make sure the images work. But besides running the bypass host registration, we run a very generic setup, so if it works for us when I can get one to test, it should work for you.



  • Thinking of getting some of the 7010 systems too. Anyone having luck or problems with the Ultra small form factor variety? Kevin, can you chime in since you’ve had success?



  • [quote=“depdesu, post: 10407, member: 3250”]I finally imaged a few of my Optiplex 7010s. While clonezilla is a lot easier and more straightforward, I look forward to using some of Fog’s features, especially the domain join and hostname changer. My problem was a networking issue which prevented the hosts on my vlan from getting bootp traffic. For some reason, any host connected directly to my core switch wouldnt boot to pxe, while PCs connected from core switch > room switch, could. A quick fix was to enable spanning-tree portfast but I’m still looking for the exact cause and best solution.

    Fog is awesome, thank you[/quote]

    I’ve got about 20+ 7010’s to image as well I can just can’t seem to get them to work. Been at it for about 3 day now. I updated them to the latest BIOS and re-installed FOG about 6 times lol

    Ubuntu 10.04
    FOG .32
    3.6.9 Kernel

    What BIOS settings, version, etc. and server settings did you use depdesu? I would love to get these working like you! Feel like I’m losing my mind lol



  • I finally imaged a few of my Optiplex 7010s. While clonezilla is a lot easier and more straightforward, I look forward to using some of Fog’s features, especially the domain join and hostname changer. My problem was a networking issue which prevented the hosts on my vlan from getting bootp traffic. For some reason, any host connected directly to my core switch wouldnt boot to pxe, while PCs connected from core switch > room switch, could. A quick fix was to enable spanning-tree portfast but I’m still looking for the exact cause and best solution.

    Fog is awesome, thank you


  • group:cid:13:privileges:mods:members

    In the BIOS, for some reason, it may not be selected under the boot menu. I’m going off of memory, so bare with me here. But, you first need to enable PXE booting in the BIOS (which i’m sure you know about) BUT you also need to click a check box under the boot priority (like 2 menu options up) to enable the NIC at the pre-boot screen when you PXE boot the machine. Have you checked to make sure both items are set correctly in the BIOS?


Log in to reply
 

419
Online

38995
Users

10714
Topics

101713
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.