FOG Server host registration issues



  • Server
    • FOG Version: 1.3.5 RC-11
    • OS: Ubuntu (latest build)
    Client
    • Service Version:
    • OS: Windows
    Description

    FOG Server is built and uses its own DHCP server. But in our attempt to create our first Host Registration when booting to the NIC on multiple computers, it does not recognize the server, and eventually just boots to Windows.

    What did I do wrong?



  • @george1421 The switch we were using also had a network connection connected to it. So when I pulled the connection, instead of using the IP address we used localhost.


  • Moderator

    @TTellez said in FOG Server host registration issues:

    option domain-name-servers 127.0.1.1;

    That is surely incorrect.


  • Moderator

    @TTellez I’m not sure what you changed in the second config file.

    But again what I’m trying to drive to ground is if you have 2 dhcp servers on the same network. We’ve established that the FOG server is one dhcp server. The question is there a second one? We can make FOG work if there is a second one (or original one) we just need to know it. You have now confirmed that this is not an isolated network.

    I keep asking if you setup a deployment network just for FOG? That was to try to determine again, is there another dhcp server some place (maybe your ISP router??)

    In your config file for the dhcp server, I see your dhcp range is .10 to .254, but your FOG server is at .163 (inside your dhcp range, which is a bit suspicious since you said it was static).

    It sounds like you unplugged something and now imaging works. Did you unplug your router? The localhost statement has me a bit confused.

    It sounds like you have imaging working now, but is this how you want it to be long term? My next step was to have you run a tcpdump to capture the pxe booting process that would tell us what is going on the wire.



  • @george1421 better?

    # DHCP Server Configuration file\n#see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    #Definition of PXE-specific options
    # Code 1: Multicast IP Address of bootfile
    # Code 2: UDP Port that client should monitor for MTFTP Responses
    # Code 3: UDP Port that MTFTP servers are using to listen for MTFTP requests
    # Code 4: Number of seconds a client must listen for activity before trying
    #         to start a new MTFTP transfer
    # Code 5: Number of seconds a client must listen before trying to restart
    #         a MTFTP transfer
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    subnet 10.1.1.0 netmask 255.255.255.0{
       option subnet-mask 255.255.255.0;
       range dynamic-bootp 10.1.1.10 10.1.1.254;
       default-lease-time 21600;
       max-lease-time 43200;
       option routers 10.1.1.1;
       option domain-name-servers 127.0.1.1;
       next-server 10.1.1.164;
       class "Legacy" {
           match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
           filename "undionly.kkpxe";
       }
       class "UEFI-32-2" {
           match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
           filename "i386-efi/ipxe.efi";
       }
       class "UEFI-32-1" {
           match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
           filename "i386-efi/ipxe.efi";
       }
       class "UEFI-64-1" {
           match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
           filename "ipxe.efi";
       }
       class "UEFI-64-2" {
           match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
           filename "ipxe.efi";
       }
       class "UEFI-64-3" {
           match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
           filename "ipxe.efi";
       }
       class "SURFACE-PRO-4" {
           match if substring(option vendor-class-identifier, 0, 32) = "PXEClient:Arch:00007:UNDI:003016";
           filename "ipxe7156.efi";
       }
       class "Apple-Intel-Netboot" {
           match if substring(option vendor-class-identifier, 0, 14) = "AAPLBSDPC/i386";
           option dhcp-parameter-request-list 1,3,17,43,60;
           if (option dhcp-message-type = 8) {
               option vendor-class-identifier "AAPLBSDPC";
               if (substring(option vendor-encapsulated-options, 0, 3) = 01:01:01) {
                   # BSDP List
                   option vendor-encapsulated-options 01:01:01:04:02:80:00:07:04:81:00:05:2a:09:0D:81:00:05:2a:08:69:50:58:45:2d:46:4f:47;
                   filename "ipxe.efi";
               }
           }
       }
    }```


  • @george1421

    • FOG server address is 10.1.1.164 or localhost

    • Hmmm, to answer 2,3, & 4 in the same one there IS another DHCP server. Yes, the router is 10.1.1.1, and NO this isn’t isolated, unless I remove the net connection, and use localhost

    EDIT: in typing this response I realized what you were asking. So I removed the external network, created the isolated imaging network, used localhost instead of the IP and BOOM we are imaging.


  • Moderator

    @TTellez Well this one is really wrong. Not sure where my head was when I gave you that command, but the initial command was wrong. Lets try netstat -an|grep 67 That should show us if the dhcp server is running on your FOG server.

    Your dhcp config file looks right. Just to confirm the following

    1. Your fog server is at IP address 10.1.1.164 and it is a static IP address. To see the current IP address of your fog server ip addr show
    2. You have no other dhcp server on the 10.1.1.x/24 subnet?
    3. Your router off this network is 10.1.1.1?
    4. Is this an isolated imaging network?


  • Not sure if this is right. :/

    # DHCP Server Configuration file\n#see /usr/share/doc/dhcp*/dhcpd.conf.sample
    # This file was created by FOG
    #Definition of PXE-specific options
    # Code 1: Multicast IP Address of bootfile
    # Code 2: UDP Port that client should monitor for MTFTP Responses
    # Code 3: UDP Port that MTFTP servers are using to listen for MTFTP requests
    # Code 4: Number of seconds a client must listen for activity before trying
    #         to start a new MTFTP transfer
    # Code 5: Number of seconds a client must listen before trying to restart
    #         a MTFTP transfer
    option space PXE;
    option PXE.mtftp-ip code 1 = ip-address;
    option PXE.mtftp-cport code 2 = unsigned integer 16;
    option PXE.mtftp-sport code 3 = unsigned integer 16;
    option PXE.mtftp-tmout code 4 = unsigned integer 8;
    option PXE.mtftp-delay code 5 = unsigned integer 8;
    option arch code 93 = unsigned integer 16;
    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    # Specify subnet of ether device you do NOT want service.
    # For systems with two or more ethernet devices.
    # subnet 136.165.0.0 netmask 255.255.0.0 {}
    subnet 10.1.1.0 netmask 255.255.255.0{
        option subnet-mask 255.255.255.0;
        range dynamic-bootp 10.1.1.10 10.1.1.254;
        default-lease-time 21600;
        max-lease-time 43200;
        option routers 10.1.1.1;
        option domain-name-servers 127.0.1.1;
        next-server 10.1.1.164;
        class "Legacy" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00000";
            filename "undionly.kkpxe";
        }
        class "UEFI-32-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00002";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-32-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00006";
            filename "i386-efi/ipxe.efi";
        }
        class "UEFI-64-1" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00007";
            filename "ipxe.efi";
        }
        class "UEFI-64-2" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00008";
            filename "ipxe.efi";
        }
        class "UEFI-64-3" {
            match if substring(option vendor-class-identifier, 0, 20) = "PXEClient:Arch:00009";
            filename "ipxe.efi";
        }
        class "SURFACE-PRO-4" {
            match if substring(option vendor-class-identifier, 0, 32) = "PXEClient:Arch:00007:UNDI:003016";
            filename "ipxe7156.efi";
        }
        class "Apple-Intel-Netboot" {
            match if substring(option vendor-class-identifier, 0, 14) = "AAPLBSDPC/i386";
            option dhcp-parameter-request-list 1,3,17,43,60;
            if (option dhcp-message-type = 8) {
                option vendor-class-identifier "AAPLBSDPC";
                if (substring(option vendor-encapsulated-options, 0, 3) = 01:01:01) {
                    # BSDP List
                    option vendor-encapsulated-options 01:01:01:04:02:80:00:07:04:81:00:05:2a:09:0D:81:00:05:2a:08:69:50:58:45:2d:46:4f:47;
                    filename "ipxe.efi";
                }
            }
        }
    }
    


  • @george1421aux|grep

    root        67  0.0  0.0      0     0 ?        S<   Mar17   0:00 [ata_sff]
    systemd+   767  0.0  0.0 102384  2536 ?        Ssl  Mar17   0:00 /lib/systemd/systemd-timesyncd
    whoopsie   967  0.0  0.1 525900 12920 ?        Ssl  Mar17   0:01 /usr/bin/whoopsie -f
    impact    2206  0.2  0.6 2675320 49684 ?       Sl   Mar17  15:56 c:\TeamViewer\TeamViewer.exe
    impact    2438  0.0  0.0 353672  8008 ?        Sl   Mar17   0:00 /usr/lib/at-spi2-core/at-spi-bus-launcher
    impact    2522  0.0  0.1 367784 11160 ?        Ssl  Mar17   0:00 /usr/lib/x86_64-linux-gnu/indicator-power/indicator-power-service
    impact    2594  0.0  0.0 178672  4744 ?        Sl   Mar17   0:00 /usr/lib/dconf/dconf-service
    impact    2767  0.0  0.0 266600  4552 ?        Sl   Mar17   0:00 /usr/lib/gvfs/gvfs-mtp-volume-monitor
    dhcpd     7671  0.0  0.1  35488 13368 ?        Ss   11:20   0:00 dhcpd -user dhcpd -group dhcpd -f -4 -pf /run/dhcp-server/dhcpd.pid -cf /etc/dhcp/dhcpd.conf
    impact    8305  3.6  5.1 1598228 413676 ?      Sl   Mar17 261:08 /usr/lib/firefox/plugin-container -greomni /usr/lib/firefox/omni.ja -appomni /usr/lib/firefox/browser/omni.ja -appdir /usr/lib/firefox/browser 8250 true tab
    impact   17477  0.0  0.2 679764 17548 ?        Sl   11:14   0:00 /usr/lib/x86_64-linux-gnu/unity-lens-files/unity-files-daemon
    impact   25118  0.0  0.0  14232   976 pts/1    S+   14:43   0:00 grep --color=auto 67
    
    

  • Moderator

    @TTellez will you post the contents of this config file? /etc/dhcp/dhcpd.conf

    This is the dhcp server configuration file running on FOG.

    <edit> also post the results of ps aux|grep 67



  • @george1421 Yes, told the installer to manage DHCP


  • Moderator

    @TTellez said in FOG Server host registration issues:

    @Wayne-Workman Updated to the 1.3.5 official.

    The Model of the host is a Dell E5570

    Now that I have updated from the RC, it is asking me to enter the tftp server?

    Usually, when the tftp server is requested, you have two or more dhcp servers serving the subnet and at least one of them isn’t configured correctly.

    Follow along with George, he’s on the right path and more available than me.


  • Moderator

    @TTellez I know I’m belaboring this point, but its important to have a clear picture.

    Before fog you didn’t have a dhcp server on your network, or is FOG on an isolated deployment network.

    The issue I’m trying to drive at is to ensure you don’t have 2 dhcp servers on your network where your computers are pxe booting. Bad things will happen if you do.



  • @george1421 and the FOG server is my DHCP server


  • Moderator

    @TTellez You installed the FOG server right?

    When you installed the FOG server, did you tell the installer to manage dhcp or did you answer No?

    One of the requirements for pxe booting is having a dhcp server on your network. Some people use fog for dhcp if its on an isolated deployment network. Or others use microsoft dhcp server or some other third party dhcp server.

    The question of how do I check, depends a lot on what you have today.



  • @george1421 Thanks for the reply George. How do I check that?


  • Moderator

    @TTellez What precisely do you have setup in dhcp for dhcp options 66 {next-server} and dhcp option 67 {boot-file}?

    And secondly what device is your dhcp server for your network?

    If you have to enter the ip address of the fog server for tftp to work then something isn’t right with your dhcp server/environment.



  • it would make sense to use the FoG Server IP for the tftp server. I entered that, and voila, it began to clone. Looks like we have resolved this issue. Fingers crossed. Thanks Wayne.



  • @Wayne-Workman Updated to the 1.3.5 official.

    The Model of the host is a Dell E5570

    Now that I have updated from the RC, it is asking me to enter the tftp server?



  • Wont let me embedd the link to the image
    http://imgur.com/a/D0wnI this is what happens on the host.

    I am a bit of a newb, and the only FoG i have used in the past was already installed and configured. So I appreciate any help.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.