Failed to get an ip from DHCP ! Tried on interfaces eth0 eth0 .



  • @kleanthis So it looks like it does not work with Lan 1 and Lan 2 but only with LAN 3 . I dont know why though . Can you check ?



  • One more thing . I have tried now on the 3rd lan port of the box . Intel Agent 1.2.6 and not 1.3.x loaded . Fog was able to grab an ip now , register and start deployment . What could be causing this ? Lan 1+2 with Intel Boot Agent 1.3.x dont work but Lan 3 which loads with Intel agent 1.2.x loads just fine . I am waiting to see if the deployment finishes fine.


  • Moderator

    @kleanthis

    /dev using udev : error creating epoll fd

    That is just a warning message and is not related to your current issue.

    OK I think the next step is to manually register this device and setup a debug capture/deploy (what ever you were doing). A debug deploy/capture will instruct the FOS engine to drop you to a command line on the target computer. From there we need to do some debugging commands like ip addr show to see if any ip address is being picked up by any interface.

    OK so can we say that RC10 was also defective in regards to this system too?



  • On my pc Lenovo L460 with single ethernet port it loads fine altough i am still getting the Populating /dev using udev : error creating epoll fd : Function not implemeted error . dont know if its relevant . But it continues on to registration. On these embedded devices fog regognices Lan 2 eth1 only . Also when trying to start the ethernet links it sais starting eth0 … then times out after 35 then sais Starting eth0 again does not move to eth1 which used to do in the past . Last time i checked that was working ok was 1.3.5-RC-10 but didnt update that until today that i had this issue.


  • Moderator

    @kleanthis what version of FOG were you on before you updated to RC16.

    What version of FOG was the last one you remembered worked correctly with this device? I know the FOS kernel (bzImage) was updated with RC14 (I think). If we can narrow down when it worked vs now we may be able to point to the kernel update that is at fault.


  • Moderator

    @kleanthis Outside of this embedded device, does imaging work correctly on traditional office computers?

    Looking into the data sheet this device has 3 network adapters, each has a different model number. LAN 1 Intel 82567V GbE, LAN 2 Intel 82583V GbE, LAN 3 Intel 82541PI GbE

    I wonder if FOS is picking an interface that doesn’t have a network adapter as its primary.



  • Same issue with Dlink unmanaged switch .
    The strange thing is that The ethernet port lights are on until init.xz is loaded , then the screen goes black for 2 secs comes back up and the lights of the machines ethernet port are off and stay off . The machine is Adnatec 3360-F
    :
    http://www.advantech.com/products/1-2jkd2d/ark-3360f/mod_db130bfd-5684-4598-b1bc-01877c5f8160

    No the issue started with the previous versions i just updated today to make sure its not something that has been fixed in latest version.


  • Moderator

    @kleanthis It sounds like the FOS engine (bzImage + init.xz) is making it to the target computer, but when FOS initializes it can’t find the network/pickup and pickup an ip address. Did this issue just start with RC16?

    This sounds like a spanning tree issue, but its strange it would just start. Could you test something for us? Please place an unmanaged network switch between the pxe booting computer and your building network switch. See if that solves the dhcp issue.

    Also for the sake of completeness, what is the the target hardware that is having an issue right now.


Log in to reply
 

334
Online

6.2k
Users

13.6k
Topics

128.1k
Posts