Issues booting UEFI devices a

  • Re: Advanced dnsmasq techniques

    Hello, I following the instruction for the dnsmaq 2.76 to setup UEFI devices to boot.

    They system I am trying to capture and image from it will get an ip address it flashes and then restarts. cannot get to the fog menu.

    I can get into fog menu and capture and deploy on Bios based devices without and problem

    I am using a hardware based dhcp device so am using dnsmaq setting instead.

  • this worked great issue resolved.

  • Moderator

    @cnkpadobi Only for humans to understand, computers don’t care. Space or no space it works the same.

  • @george1421 Thanks for this… just a quick clarification is there a space after the comma before the ip address

  • Moderator


    In your ltsp.conf file add in the following lines below this one

    # PXE menu.  The first part is the text displayed to the user.  The second is the timeout, in seconds.
    pxe-prompt="Booting FOG Client", 1

    and before the


    Insert these:

    # PXEClient:Arch:00000
    pxe-service=X86PC, "Boot BIOS PXE", undionly.kpxe
    # PXEClient:Arch:00007
    pxe-service=BC_EFI, "Boot UEFI PXE-BC", ipxe.efi
    # PXEClient:Arch:00009
    pxe-service=X86-64_EFI, "Boot UEFI PXE-64", ipxe.efi

    These lines are only needed when your main dhcp server is giving conflicting next server information. Lets see if that fixes your uefi booting.

    There is one additional condition that dnsmasq can (mask), this is where you force the next server as part of the pxe service command, where you append the IP address of your fog server to the pxe-service line. You will need to do this for each pxe-service command in your ltsp.conf file you inserted above.

    pxe-service=BC_EFI, "Boot UEFI PXE-BC",ipxe.efi,<fog_server_ip>

    (this post is in response to several IM chat sessions to get the OP going. legacy mode is working, its just giving the uefi systems an error during iPXE kernel booting)

  • ok sorry,

    So I am still gett this error
    dnsmasq: bad option at line 2 of /etc/dnsmasq.d/q

    the only thing inthe ltsp.conf on line two is port=0

    there are no other config files in the directory

  • Moderator

    @cnkpadobi removed. If its there it will be read. If you are concerned about the content then move them to /root (root’s home) or some other location, but not in the /ete/dnsmasq.d path.

  • @george1421 should those configure files be rename or removed?

  • Moderator

    @cnkpadobi lets remove all but the correct one (like the one I posted). We can only have one configuration file in there with the options I provided. AND if that is the case /etc/dnsmasq.conf should remain unchanged from the original install.

    I would suggest that we keep the standard file of /etc/dnsmasq.d/ltsp.conf and then remove the rest.

  • @george1421

    YES, all 3 config files are in that directory

  • Moderator

    @cnkpadobi said in Issues booting UEFI devices a:

    @george1421 so if I run the sudo netstat -an|grep 4011 it should give me something correct versus taking me back to the prompt?

    If it takes you back to the command prompt, then that tells us the dnsmasq is NOT running on your fog server.

  • Moderator

    @cnkpadobi said in Issues booting UEFI devices a:

    ltps.conf ltsp.conf ltsp.conf~ network-manager README

    I don’t quite understand the above line. Taking it out of context it appears there are more than one configuration file.

    1. ltps.conf
    2. ltsp.conf
    3. ltsp.conf~

    In that directory.

  • @george1421 so if I run the sudo netstat -an|grep 4011 it should give me something correct versus taking me back to the prompt?

  • @george1421

    Here are the files listed

    ltps.conf ltsp.conf ltsp.conf~ network-manager README

    that command does not produce any results

  • Moderator

    @cnkpadobi are there any other config files in the /etc/dnsmasq.d directory?

    dnsmasq will read all configuration files in /etc/dnsmasq.d directory. If there is more than one that has conflicting settings it will throw an error.

    Now there is another check to see if dnsmasq is running netstat -an|grep 4011 It should return something that looks like this if its running. Port 4011 is managed by dnsmasq.

    sudo netstat -an|grep 4011
    udp        0      0  *                          

  • @george1421 not sure this is what it says

    # Don't function as a DNS server:
    # Log lots of extra information about DHCP transactions.
    # Set the root directory for files available via FTP.
    # Disable re-use of the DHCP servername and filename fields as extra
    # option space. That's to avoid confusing some old or broken DHCP clients.

  • Moderator

    @cnkpadobi ok what is the illegal keyword on line 2 of the config?

  • @george1421 I dont think it is started but when I try I get this message

    dnsmasq: illegal repeated keyword at line 2 of /etc/dnsmasq.conf

  • root@imagingvm:~# nobody 1502 0.0 0.0 33140 3132 ? S 15:41 0:01 /usr/sbin/dnsmasq --no-resolv --keep-in-foreground --no-hosts --bind-interfaces --pid-file=/run/sendsigs.omit.d/ --listen-address= --conf-file=/var/run/NetworkManager/dnsmasq.conf --cache-size=0 --proxy-dnssec --enable-dbus=org.freedesktop.NetworkManager.dnsmasq --conf-dir=/etc/NetworkManager/dnsmasq.d
    root 14476 0.0 0.0 18316 2292 pts/14 S+ 17:42 0:00 grep --color=auto dnsmasq
    nobody: command not found
    root@imagingvm:~# root 14476 0.0 0.0 18316 2292 pts/14 S+ 17:42 0:00 grep --color=auto dnsmasq

  • Senior Developer

    @george1421 I’ve seen this a couple of times as well, but I don’t need the moderator rights to get it, basically I click on the file it gives me an error page. If I change the name just a tiny bit I get 404, when I hit back it prompts to download the file.

Log in to reply

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.