Fog Server - Database Access Problem



  • Server
    • FOG Version: 13
    • OS: Ubuntu 16.04
    Client
    • Service Version:
    • OS:
    Description

    Updated to the trunk version of Fog a year ago or so (SVN Revision 5948) and all has been well but this morning a co-worker noticed an update message when he accessed the Fog web gui but was unsure about it and closed out the message box. Now, we are getting the below message:

    Database Schema Installer / Updater
    Your database connection appears to be invalid. FOG is unable to communicate with the database. There are many reasons why this could be the case. Please check your credentials in /var/www/fog/lib/fog/config.class.php. Also confirm that the database is indeed running. If credentials are correct, and the Database service is running, check to ensure your filesystem has enough space.

    Any ideas?

    The database password hasn’t changed. I restarted the MYSQL database. Drive space is fine.


  • Developer

    @Motech09 said in Fog Server - Database Access Problem:

    Nevermind, I fixed it.

    What was wrong and how you fixed it really helps others in their troubleshooting/resolution.



  • Nevermind, I fixed it.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.