Primari mac 02:00:00:00:01:00



  • Server
    • FOG Version: 1.3.4 svn 6064
    • OS: ubuntu server 14.06

    Hello,
    I’ve setted up quite easy a server, whit a synology storage node and everythings works fine…

    Then, since we want to grant access to FOG at the IT admin of the company, I’ve setted up the https webgui and the AD bind…Great, everythings works!

    BUT… When I want to register a host via Client registration…I only can use the msi option whit the HTTPS switch…It works but… the primary mac is setted to 02:00:00:00:01:00 for every machine… I need to change it manualy (selecting the real primary MAC from the “alternative mac” list of the “pending host”)…

    Top of all, everytime I reboot the pc, when I login to it the “pending mac” comes out again ( 02:00:00:00:01:00) and I have to delete it everytime…

    did you have some suggestions??



  • @Tom-Elliott said in Primari mac 02:00:00:00:01:00:

    @Tom-Elliott thanks Tom…I’ve done this, and I would make more test during this days and give you an update!


  • Senior Developer

    @brusa.matteo And if you follow my suggestion of adding the 02:00:00:00:01:00 mac address to the filter, things should be better.



  • @Tom-Elliott Thanks Tom…sorry but I’ve posted after an hard-days…
    I will try to explain better:

    I’ve setted up a Fog installation, and everythings works fine.
    I’ve setted up this special configurations:

    LDAP connection
    https web gui
    synology nas used as first storage node
    created a usb-key with ipxe for those devices that dosen’t support pxe (and because actualy we have another pxe-based service)

    everithings works fine and I cant push o create images, install snapin or snapins pack…

    The only strange thing is that, since we have forced https for the web-gui, the client MUST be installed in msi form whit this string in order to work:

    msiexec /i C:\FOGService.msi /quiet USETRAY=“1” HTTPS=“1” WEBADDRESS=“x.x.x.x” WEBROOT="/fog" ROOTLOG=“1”

    After this, the fog client starts, creates the “pending host” on the webgui, but the host has the “primary mac” setted to “02:00:00:00:01:00” (every host that I try to register directly with the client)… If I look inside of the host, I can see the “real” mac of the pc, and I can change the primary with the real mac. After this the host work fine as the others… But, everytime I reboot the client, the “02:00:00:00:01:00” mac comes out again, as a pending for approval mac ( i can delete it from the list from “MAC address list” menu )…

    I hope this is more clear… thanks a lot


  • Moderator

    Brusa,

    We recommend for first setup of FOG to start simple because there are many parts of FOG and getting PXE booting to work in some networks is hard. I can say you started with very complex setup with LDAP Login, Synology NAS as FOG storage. I want to tell you Bravo on your setup!!

    @Tom-Elliott I find this very strange since 02:00:00:00:01:00 is not a valid mac address (vendor unknown). Where would this value come from? Initially I was thinking the OP was using a usb ethernet adapter, but…


  • Senior Developer

    If you prefer, please use your native language if possible? I think I understand…sort of… what you’re saying but it’s very hard to follow.

    I suspect, however, you simply need to add the 02:00:00:00:01:00 mac address under FOG Configuration Page->FOG Settings->FOG Client - Host Register->FOG_QUICKREG_PENDING_MAC_FILTER field and save.


Log in to reply
 

495
Online

39193
Users

10845
Topics

103221
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.