Hosts will not auto-join domain after imaging



  • ####### Server

    • FOG Version: 1.3.0-RC-21
    • OS: Ubuntu 14.04
    Client
    • Service Version: 0.11.5
    • OS: Windows 10 Enterprise 64-bit
    Description

    When I image laptops with my Windows 10 Enterprise 64-bit custom image, they will not auto-join my Windows domain. The log seems to indicate that it thinks the machine is already joined to the domain. I have checked and re-entered the credentials. 0_1488913805374_fog.log



  • Ok - found my problem - those dates in the Fog log got me to wondering why there weren’t any recent entries… Service was not starting - I had not updated my SetupComplete.cmd for the new client that I included in the new image:

    Old client SetupComplete.cmd command to start the service:

    sc config “Fog Service” start= auto

    New Client SetupComplete.cmd command to start the service:

    sc config “FogService” start= auto

    Voila! Working again! Thanks for your input - I will probably rebuild a clean image at some point, but this got my old patchwork image going!


  • Moderator

    @awhitmer If you did deploy to to a physical machine and then connected it to AD, I might understand your issues. If you are going to start over (which I think your best next option), you might want to consider building your reference image using MDT. This way you can automate the reference image building process. I can say it will probably take you about 2 man weeks to perfect your image through MDT using the lite touch process. But once its done, you can reproduce your reference image by just selecting the proper task sequence. Windows, all updates, and any applications can be installed with MDT. As for the drivers, if you want to make a hardware specific image you can have MDT push the proper drivers to the VM. Or you can make a hardware independent reference image and push the drivers with FOG’s postinstall scripts. Either way works. But by using MDT you don’t have to worry about the rearm count, because the image is rebuilt from the ISO every time, so the rearm count is always 0.

    As for the FOG client, it is recommend that you install it in the reference image, but disable it from running. Then in your setupcomplete.cmd file set it to active and start the service. That way the FOG client doesn’t kick in too early in the process and reboot the computer before OOBE completes.



  • Well I made the image by putting a generic image off of a VM onto a new laptop - then making some further customizations and installs - It did actually join the domain off of the generic image with the old client - I unjoined the domain and sysprepped before capturing, but after typing all of this, I see that my issue may be just too much baggage on this image!


  • Moderator

    I agree 1.3.0-RC21 is the first step. The devs will require you to be on the latest release (1.3.5RC11 at the time of this post) to ensure your issue hasn’t already been addressed.

    And I agree with Tom, its best practices to never connect a reference image to AD before its cloned, even if you detach it from the domain then capture it. Adding to the domain tattoos the image with AD making it much more difficult to bulk deploy.


  • Senior Developer

    ------------------------------------------------------------------------------
    --------------------------------HostnameChanger-------------------------------
    ------------------------------------------------------------------------------
    2/15/2017 8:19 AM Client-Info Client Version: 0.11.5
    2/15/2017 8:19 AM Client-Info Client OS:      Windows
    2/15/2017 8:19 AM Client-Info Server Version: 1.3.0-RC-21
    2/15/2017 8:19 AM Middleware::Response Success
    2/15/2017 8:19 AM HostnameChanger Checking Hostname
    2/15/2017 8:19 AM HostnameChanger Hostname is correct
    2/15/2017 8:19 AM HostnameChanger Attempting to join domain
    2/15/2017 8:19 AM HostnameChanger Host is already joined to target domain
    ------------------------------------------------------------------------------
    

    First I’d highly recommend updating to at least 1.3.4 (though with ubuntu you’re probably better with the 1.3.5-RC series).

    Second, is the image in a state where it was already joined to the domain when you imaged it? It appears, to me, the log is from February 15, 2017. Do you have a more recent log?


Log in to reply
 

390
Online

39.5k
Users

11.1k
Topics

105.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.