HP ProBook 650 G3 - Not fully capturing/deploying



  • Hi all, having a bit of an issue creating a working image of the above machine. Basically when I boot into FOG and do any of the options it will list a number of errors before continuing on with the task and completing as per normal. I had this happen when I did the quick registration, capture and then deploy however after doing the deploy, the laptop won’t boot to Windows as it’s missing the bootloader file so obviously the error is something I can’t ignore.

    Have an older HP 650 G1 and I was able to capture and deploy the image fine so I’m pretty certain the issue lays with this new machine or at least there’s a setting I need to change to enable my FOG system to work with it.

    Here’s the error I get once it starts a task from the FOG system -
    0_1488846877342_1.jpg

    It will then continue on with the task and complete it. Below is what it showed after completing copying the image on the FOG server back to the machine -
    0_1488847531144_2.jpg
    0_1488850220943_3.jpg

    Extra info if it’s of any assistance:

    • Server: Ubuntu 16.04.2 LTS
    • FOG: 1.3.5-RC-10
    • DHCP on Windows 2012. Using undionly.kkpxe (found it to be the only one where I haven’t had to hit ‘S’ then type ‘Autoboot’ to automatically log into the FOG system.
    • Secure boot disabled, unable to disable UEFI as such but I turned on Legacy which is what I was using to boot to network.
    • I did attempt ipxe.efi (before finding out how to turn on Legacy) which would boot to network but whenever I attempted to do any of the Fog tasks it would just revert back to the menu.

    Hopefully that’s not too much of an information overload. Basically I assume the issue is something to do with the errors I’m receiving in the first picture but I have no idea what they are/how I’d go about fixing those.



  • Glad I took two different kind of images.

    Single disk clone - Went through the process, on boot the file I created was still there, the only difference was it had uninstalled a lot of the drivers such as the NIC…

    Multiple partition clone - Seems to have worked!

    Thanks again for the help guys, much appreciated



  • @Tom-Elliott Testing it out now, it was able to create a single disk clone which it hadn’t worked well with previously, creating a multiple partition clone as well just in case so hopefully when I try deploy the image it will work.

    Will report back later, thanks again.


  • Senior Developer

    @dylan123 Possibly, try installing RC-12 to see if it may help?

    The messages your’e seeing there, however, shouldn’t have any problems in regards to maintaining the system in a bootable state.



  • @george1421

    Just had a look but it’s already got the latest BIOS on the system so that’s not causing the problem unfortunately. Not sure I’ll get much more of a chance to test this machine as I need to set it up for a user shortly and it’s the only G3 we have at this stage.

    Thanks for your help though, any other ideas, feel free to mention them and I can test them out when I get a chance. Will be attempting to image a surface 3 and 4 so I’m sure I’ll going through the forums/posting again.


  • Moderator

    @dylan123 Yes firmware (bios) on the laptop. Please make sure the its up to date. Its a long shot but if this is a new model the firmware may get updated between model creation and it arriving at your door.

    As for the dhcp messages. Can you place a dumb (unmanaged switch) between the pxe booting computer and the building switch? When we see this sometimes it indicates the building switch is running spanning tree, but not one of the fast spanning tree protocols (RSTP, MSTP, fastSTP, etc). Default spanning tree takes 27 seconds to to into the forwarding state when the link is enabled. The link will momentarily drop as the booting process transitions between PXE, iPXE, and then FOS. The error messages from the image are coming from FOS (linux kernel) isn’t able to get a dhcp address. At this point we are beyond the iPXE kernel (undionly.kpxe, ipxe.efi).



  • @george1421
    Firmware as in the one on the laptop? I haven’t checked yet, didn’t really think that could affect the imaging process, it is a brand new laptop though but I can check that out if you think that might be the issue.

    Will run an update, I only just updated my FOG system the day before to RC10 for 11 to come out the next day!

    When I was in UEFI mode, it wouldn’t boot to network at all (just sort of said booting to network then would go back to boot menu) apart from when I had it set to the ipxe.efi. When I was on that and on the FOG menu, clicking on any of the options would go for about 1 second before it would go straight back to the fog menu with the timer going down before it would continue to boot to Windows. In that short time, I don’t see a single error show.

    Edit:
    Just adding to the above, when I boot to fog even on the laptop I was able to create a working image with, I do get the following error -
    0_1488946030523_1.jpg

    Don’t know what the error creating epoll fd means. The part under I think is just trying to find the DHCP/network. I’ve noticed on this network, computers can take a little while to get a connection so I assume that’s why I get the sending discover messages for a little while before it eventually says “udhcpc: started, v1.26.2” “udhcpc: sending discover” and continues on with whatever task I’ve selected.


  • Moderator

    Is the firmware up to date on this device? These errors are kernel errors that should not be.

    I can say you might want to update to RC11, since there has been quite a bit of effort put into disk imaging. But without the kernel booting correctly the imaging part is not the first concern.

    When the system was in pure uefi mode. When you select a option like register from the ipxe menu did the kernel load correctly (even if the end product was a failure)? With secure boot being turned off, the FOS engine should boot.


Log in to reply
 

503
Online

39009
Users

10724
Topics

101881
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.