Linux Deploy problem.



  • Server
    • FOG Version: 1.3.5_RC_1
    • OS: Ubuntu 16.04
    Client
    • Service Version:
    • OS: Ubuntu 16.04
    Description

    Hello!
    I’m expriecining problems while trying to deploy Ubuntu 16.04 image with FOG. I’m able to capture and deploy the captured image and I get no errors during the deploy / capture process, although - after the deployment ubuntu won’t load on the target machine and i’m just getting a blank black screen (image attached)

    Suggestions?

    Thanks!
    0_1488721051669_20170305_152752-min (1).jpg



  • @PerC I get this when deploying Windows images in brand new Hard Drivers, then I boot with a Live Linux and tell where to find the bootable partition.


  • Moderator

    @PerC I’m a little lost here where things worked, got fixed, and still same error.

    Can you confirm that you did indeed update to 1.3.5RC14 (as of today)?

    Also this appears to be a uefi system. You are saying that you still get the blank screen from your original post? If this IS the case, as a test change the boot order of this client from network (first) to hard drive (first). Does the system boot correctly into the OS?

    If yes, then we need to focus on the UEFI exit mode FOG uses for this hardware.


  • Senior Developer

    You updated?

    You’re certain you’re running, at the least, RC 12? Sorry a week apart for information makes me need to know more information than “Still the same problem”.

    I typically hate this answer ever as it doesn’t help us get to a solution. There could be any number of reasons the “same problem” is occurring and to know if the “same problem” is the same problem because nothing changed is the first step in finding this out.



  • @Tom-Elliott
    Still the same problem.


  • Senior Developer

    mind updating to rc-12 and retrying the deploy process? I don’t expect any difference, but possibly it may have been related to the UUID setting we found last night.



  • @Tom-Elliott Secure Boot is off :(


  • Senior Developer

    @PerC Most often, this occurs because you captured the image with SecureBoot on?



  • Hi!

    Thank you very much for the reply.
    I have upgraded to RC10. and also tried your solution (changing the host exit type to refInd) - the problem still occurs.

    Although - I have found the problem (!!) but I don’t have the solution for it. The problem is definitely with the routing to the EFI file to handle the boot process. I tried to manually navigate to the Ubuntu EFI file from the EFI shell on a machine that I have just deployed the image on, and the Ubuntu OS booted successfully… any suggestions?? maybe post installation script or something?

    Thanks!


  • Moderator

    Can we assume this system is in uefi mode? IF SO, then I might suggest that you change the uefi exit mode for this device to rEFInd.

    Since you are running 1.3.5RC1 I might suggest you update to the latest release, RC10. You may want to wait a few days or so because RC11 is getting ready to be released and has quite a few bug fixes in the area of resizing the image during image deployment.


Log in to reply
 

489
Online

39009
Users

10724
Topics

101880
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.