UNSOLVED Windows 10 Ent 64bit upload issues

  • Server
    • FOG Version: 1.3.5 RC3
    • OS: Ubuntu 16.04.1
    • Service Version: latest
    • OS: Windows 10 Ent 64bit

    What is the Failed to read back partitions (runPartprobe) error about?

    also error: Populating /dev using udev: udev[2533]: error creating epoll fd: Function not implemented
    unable to locate image store (/bin/fog.download)

    I ask this because all seems to work well inside Fog but it will not let me create a new host…it get a blank screen with error:

  • Moderator

    @butch2861 As the Church Lady once said, “Well isn’t that special…”

    Now that we know its a hardware class specific error. I wonder if this hardware is having a problem with the 64 bit kernel. We have seen some specialty hardware that has a 64bit CPU but externally its 32bit. I’m not saying this is specialty hardware, it could be similar in function.

    I wonder what the results would be if you went into the host definition (You may have to manually register it if the kernel is panicing) set the kernel to bzImage_32 and the inits to init_32.xz This will force FOG to send the 32bit kernels to the client no matter what it reports to iPXE.

    From your other screen shot I see 2011. Is the firmware the latest version available for this hardware. Lenovo has been known to have flaky early release firmware.

  • @george1421 okay tried on another identical pc and the attached error is my error…0_1488581530232_0303171634.jpg

  • Moderator

    @butch2861 First lets not mix issues. Right now you have a hardware (guess) error since its not even booting the FOS engine on the target hardware. So anything you could have done to the OS on the hard drive is not even in the picture yet.

    As for your second question. As for the FOG client, that is correct (in a way) you can / should install the fog client before you sysprep the image. It can be immediately before or way before you sysprep. You just need to ensure that the service is disabled just after you install it. Then in your setupcomplete.cmd file, re-enable the service and then start the service. As soon as the FOG client checks into the FOG server it will start doing its job. We just don’t want it doing its job too early in the process before OOBE has completed.

  • @george1421 Yes I do and I will give that a try…also noticed I had NOT deleted the partition and had 2 Windows.old Folders…could have been issue too…I have a ques. 4 u; I wait until right before I run sysprep to install the Fog Client and make sure the service is NOT running before I kickoff sysprep /generalize /oobe /shutdown /unattend:unattend.xml , when it shuts down I then go to Fog Server and run the client capture image feature then turn on pc to upload Image…is this the correct procedure for this?

  • @george1421 I was just going to ask the same question.

    As @Sebastian-Roth suggests, this appears to be a problem with this particular system. It’s failing to use the CPU itself. Maybe this is Firmware related? Maybe there’s actually a problem on the mb of this system entirely?

  • Moderator

    @butch2861 Do you have a second one of these systems? I’m thinking what Sebastian posted. The kernel died just starting up. It sounds like a hardware failure (probably bad ram). A second unit might help us determine of “this” system is bad or all of the same model have an issue.

  • Moderator

    @butch2861 I’m going to recommend then you update your FOG server to 1.3.5RC10. We may have the get the developers involved, and that will be the first thing they will request.

    <edit> OK a bit red faced. Was looking at your OP for fog version number. I read too many threads to remember where I was in all of them, my apologies</edit>

  • @george1421 Should I reconfigure the AHCI Sata settings in BIOS to be IDE instead of AHCI? The BIOS has no uefi or secure boot settings…all security has been turned off in BIOS

  • Moderator

    @butch2861 Kernel oops at such an early stage sounds as it could be a hardware issue. Most probably memory? You might want to run memtest for a couple of hours and see if it is all well.

  • Moderator

    @butch2861 Ok tell us a bit more about the pxe booting device. I see that it’s a lenovo.

    Is this device in uefi mode or bios (legacy) mode?

    If its in uefi mode, did you turn off secure boot?

    I also noticed in the picture the firmware was from 2011, so this is not a super new device either.

  • Still having issues after update, now getting this error…0_1488492793629_0302171553.jpg

  • @george1421 Thanks George…I was on RC-3 and just ran the update and walla!!!

  • Moderator

    The first thing the developers are going to ask is if you can upgrade to the latest rc release (RC10) first. They will want to make sure they haven’t already addressed this issue.

    Also it would help greatly if you can snap a picture of the error with a mobile and post it here. The context of the error also gives clues to where exactly in the process its failing.