Fog DHCP issue on isolated network



  • I am using Fog as DHCP on a private network with a Cisco switch (default settings) to image laptops. I just imaged my first set of laptops which was 20. Upon setting up the next set about half of them were exiting the PXE boot because “No Proxy DHCP or DHCP offers were received.” I always check to make sure dhcp3-server is running…it is fine. I am wondering if there is an IP address limitation…leasing, quantity…I don’t know. I did change the default and max lease times under the suspicion that the IPs weren’t being released…still no luck. Can someone help me out? I have my DCHP config file and will post it…please help me. I am on the chopping block here.

    [ATTACH=full]139[/ATTACH]

    [url="/_imported_xf_attachments/0/138_dhcpconf.png?:"]dhcpconf.png[/url][url="/_imported_xf_attachments/0/139_dhcpconfig.jpg?:"]dhcpconfig.jpg[/url]


  • Moderator

    Ask your administrator about turning on portfast for all the ports so there no delay between them being connected and being active. See if that helps.

    I’m not sure why your dhcp daemon is not autostarting. Did you try adding it to the default runlevel or making sure the startup script is getting call? dmesg or /var/log/syslog might have some clues.



  • I will get into the switch and enable portfast. Maybe that will fix the problem. Keep fingers crossed.



  • The switch I am not sure about…I had my Network Administrator reset it to defaults so that it would multicast. I am using Ubuntu 10.04 with Fog 0.32. I didn’t reboot the server after the first imaged set. I setup another round and started booting them which is where I ran into the “No DHCP offers received” snag. Once I ran into this I did restart the server as well as start dchp3 manually (which I have to do every time on a reboot). Still have the issue.


  • Moderator

    Did you enable portfast on the switch or give the units 30 seconds of wire connectivity before trying to boot them? Might be a STP issue with the ports not being active by the time the clients try to PXE boot.


  • Moderator

    What version of Ubuntu are you using and did you reboot the Fog server between imaging attempts?


  • Moderator

    This post is deleted!


  • [quote=“chad-bisd, post: 4725, member: 18”]What is the static IP address of the Fog server interface you are using?[/quote]192.168.1.1…gateway and DNS are the same as well.


  • Moderator

    What is the static IP address of the Fog server interface you are using?


Log in to reply
 

441
Online

38948
Users

10699
Topics

101512
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.