New DHCP Server - Client TFTP Error



  • Server
    • FOG Version: 0.32
    • OS: Ubuntu 10.04 LTS
    Client
    • Service Version: 0.1
    • OS: Windows 7
    Description

    Clients are getting stuck upon PXE boot at TFTP (open timeout). I configured a new DHCP server yesterday by exporting DHCP settings from the old server and importing DHCP settings to the new server. The scope options haven’t changed. Is there a setting on the FOG server that could be pointing to the old server? …maybe the pxelinux.0 file or something else? Or could there be a TFTP setting on a Cisco switch pointing to the old server? I set FOG up 7 years ago and use it all the time, but I a bit “foggy” regarding the configuration. Pun intended : - ) It’s been too long to remember the configuration.



  • @x23piracy I will. Thank you.



  • @emerinea well done, but you should check wether dns is not working correctly or if the hostname is wrong.
    Anyway it’s time to go to a newer version you should migrate if you find the time.

    Regards X23



  • @x23piracy Nice work. Changing option 66 from the hostname to the IP address did trick. Clients are booting fine now.


  • Developer

    @x23piracy @emerinea The adjustments that x23 is recommending will likely fix the issues you are seeing.

    Using DNSMASQ will never require these settings and will bypass them by using a proxy DHCP server for devices in the tftpboot protocol.

    Either should work :)



  • @emerinea i bet it’s an dns issue and your client cannot resolv fogserver, is this really it’s name? try it ip address please.

    alt text

    Regards X23



  • @x23piracy Is this what you are referring too? This is screenshot of the server’s DHCP Manager. DHCP Manager.



  • @emerinea you dont need to open the bootfile, the dhcp option 66 is pointing to the ip of the fog server

    alt text

    Don’t be confused of undionly.pxe or ipxe.efi you have to stick at pxelinux.0



  • @Jaymes-Driver I would prefer to get it working. The only thing that has changed is the IP address of the DHCP server. It has to be a simple fix. I’m not sure where to make that change. Is it possible to view the contents of the pxelinux.0 file? I do not see a way to open it.



  • @emerinea are you sure dhcp option 66 (ip) for the fog server is correct? can the client reach the ip while running any os?
    like @Jaymes-Driver say going to a newer fog version would be the best decision.


  • Developer

    @emerinea You can spend time troubleshooting the real issue, or you can get back to working… I would recommend using DNSMASQ to help your machines to resolve to your tftp server since you are still on FOG version 0.32

    https://wiki.fogproject.org/wiki/index.php?title=Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#Setup_and_Configuration

    Use this link.

    Let us know if you have issues.

    You should really think about moving on to FOG 1.3.5 as a lot has changed and it will help us to assist you further. Not that any FOG project was ever supported the 0.32 version is quite old.

    I would grab some hardware and set up a new server and moth ball the old one.

    Hope this helps!



  • @x23piracy

    • Windows DHCP Server 2012 R2.

    • Using pxelinux.0 file.

    • Error:
      PXE-E32 TFTP open timeout
      PXE-M0F: Exiting Intel Boot Agent


  • @emerinea

    • what for a dhcp is it?

    • which bootfile do u use?

    • what’s the exact error from a client trying to boot from network?



  • @x23piracy Yes. Those are configured in DHCP. Really nothing has changed except the DHCP server name and IP address.



  • @emerinea do you remember the dhcp options 66 and 67? :) you say new dhcp server, if so maybe 66 and 67 are missing, your clients need to know the fogs server ip and the boot filename.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.