Fresh install FOG 1.3.4 on Ubuntu Server 16.04.1 LTS Fails



  • FOG 1.3.4 fails to install on Ubuntu Server 16.04.1 LTS. Following this guide at https://wiki.fogproject.org/wiki/index.php?title=Ubuntu_16.04_Server

    First, this is setup in Hyper-v. I get the Ubuntu server up and running, do the update/upgrades for it and start to install FOG but fails on installing some packages. The packages for Apache2, Apache mod and all PHP7.1 fails. Not sure if it a connection error or what cause I don’t see any errors other than it failed. Is there something missing from that guide. I have gotten this to work once before but had to start again from scratch due to IP errors from another DHCP server which caused someone to nuke the FOG server.


  • Moderator

    @psyfer9983 After changing the OS’s addressing & dns and gateway and such, the tool in here called updateIP will change all the needed spots for FOG’s files. https://github.com/FOGProject/fog-community-scripts

    It will also re-write dhcpd.conf properly if the box is configured to do dhcp - and will do so correctly even for up to 4 interfaces on one system.



  • To Change the IP-Adress, Gateway, DNS etc. modify the File “interfaces” located in /etc/network



  • It didn’t matter which gen I used, it failed not matter what. Anyway, I just tried again this morning. It installed without a problem at all. I still think it was a connection error and I’m wandering if the servers for the packages that I had problems with were slammed or something. Anyway, its working now. By the way, how would one change the IP address of FOG. I link to a guide would be great. I’m going to backup the VHD file and give it to a friend but need to change the IP to match his network.



  • i get Error too if i install the Version in Generation 2 Mode under Hyper-V.
    If i try this in Generation 1 Mode i get no Problems.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.