HTTP 500 Error



  • Server
    • FOG Version: Latest trunk
    • OS: Centos 7
    Description

    Trying to load the /fog/management page after completely fresh install of Centos 7 and Fog and getting a 500 error. Checking /var/log/httpd/error_log I am seeing the following:

    [Mon Jan 30 15:41:32.771787 2017] [:error] [pid 21685] [client 172.16.1.153:51263] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 105
    [Mon Jan 30 15:42:18.075891 2017] [:error] [pid 21686] [client 172.16.1.153:51280] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 105
    [Mon Jan 30 15:44:11.434489 2017] [:error] [pid 21687] [client 172.16.1.153:51293] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 105
    [Mon Jan 30 15:44:50.246036 2017] [:error] [pid 21689] [client 172.16.1.153:51310] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 105
    [Mon Jan 30 15:45:28.739056 2017] [:error] [pid 21686] [client 172.16.1.9:54366] PHP Fatal error: Cannot create references to elements of a temporary array expression in /var/www/html/fog/maintenance/create_update_node.php on line 25
    [Mon Jan 30 15:46:28.856688 2017] [:error] [pid 21687] [client 172.16.1.153:51322] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 105
    [Mon Jan 30 15:47:23.661965 2017] [:error] [pid 23957] [client 172.16.1.96:50435] PHP Parse error: syntax error, unexpected ‘&’ in /var/www/html/fog/commons/init.php on line 105

    Now if I edit /var/www/html/fog/commons/init.php and remove the “&” in line 5 the management page then says I need php 5.5 and I am currently running php 5.4.16. I have fully updated centos when I check my php version it does show 5.4.16 installed, but yum update doesn’t show any packages to be updated. Any ideas, this is the third Fog server I have built and the only one that has given me any problems like this.



  • Ok, I found the issue. The Geo IP filter on the firewall was preventing accessing the remi repository, which was keeping me from updating php. Disabled the Geo IP filter and ran a fresh install and everything is working like a charm.

    Thanks again guys for the help!


  • Senior Developer

    @Erek-Beckman Please install the remi repository, or try running:

    yum -y update php* --enablerepo=remi,remi-php56
    


  • @Wayne-Workman Yes I am following https://wiki.fogproject.org/wiki/index.php?title=CentOS_7 for the install.

    I am not sure on the exact version as I can’t get into the gui, I couldn’t find a way to check the version from cli. Is there a command to check the version of fog that is installed?


  • Senior Developer

    What is version “Latest trunk” exactly?


  • Moderator

    FOG requires php 5.6 or higher. The fog installer should install the remi repository and get you to 5.6 or 7.x. So that’s not working for some reason.

    Are you following this article? https://wiki.fogproject.org/wiki/index.php?title=CentOS_7

    What version of fog? Saying ‘latest version’ isn’t good enough, we need exacts.


Log in to reply
 

435
Online

39000
Users

10717
Topics

101757
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.