Can't access FOG Management Portal after clean OS and FOG install



  • Server
    • FOG Version: 1.3.0
    • OS: Ubuntu LTS 14.04
    Client
    • Service Version:
    • OS:

    Hey guys,

    I’ve been banging my head against the wall for a day or so on this one.
    I ran into an issue with a storage node earlier this week, so instead of trying to troubleshoot and diagnose, I decided I’d just start over from scratch since we did not have any prod images uploaded as of yet. I reinstalled Ubuntu and then FOG on top of it, and am running into an issue where I cannot access http://FOGSERVER/fog/management from any web browser. Of course, I installed Ubuntu without a GUI so I cannot test from localhost. However, this was working perfectly before in the same environment yesterday.

    I assigned a static IP on eth0 and can ping an IP address, but no hostnames despite settings dns-nameservers. However, I can ping the FOG server via hostname and IP address from another host.

    We are running this VM in VCenter5 on an ESXi host.

    Any help is appreciated!

    Thanks,
    Alex



  • @Tom-Elliott Please ignore my previous post about this. I gave up on my current installation and reinstalled CentOS 8 and then tried to reinstall FOG again. I found a very useful Wiki article for CentOS7 and followed that. I posted a new issue elsewere in the forum so this particular problem no longer exists after a system re-install. I would post a new thread but I don’t know how. I don’t use forms much so I don’t know enough about them. To be honest, I wasn’t expecting folks to be so responsive on here (based on my previous experience with message boards) and I thank you for taking the time to reply.


  • Moderator

    @EricZ said in Can't access FOG Management Portal after clean OS and FOG install:

    I tried running sudo ufw status

    ufw is a Ubuntu “thing”, under centos its systemctl status firewalld. To follow on what Tom said, since this thread is 2 years old, please create a new thread because your conditions are probably different. Include enough detail so we know how you have things setup.

    In your case I would ensure that selinux is set to permissive and you issue a systemctl disable firwalld then reboot the system and rerun the FOG installer one more time.


  • Senior Developer

    @EricZ Seeing as this post if from 2017, can you provide more details and start a new thread?

    For example:
    What version of fog are you installing?

    What CentOS version is installed?

    When, and where is UFW referenced for a CentOS installation to begin with?



  • @Tom-Elliott I’m having the same problem after a new install using CentOS. I tried running sudo ufw status but it says the command isn’t found. The website wouldn’t work during or after install.



  • @Tom-Elliott
    Running that command, I get - Status: inactive

    I’m seeing the same issue with Ubuntu 14.04 and 16.04 in a VMware environment with 1.3.4.



  • @Tom-Elliott
    Just installed version 1.3.3 / SVN Revision: 6061 — installed without a hitch.



  • @Tom-Elliott
    Using the instructions at https://wiki.fogproject.org/wiki/index.php?title=Installation#Current_development_version I ran the installation. The only problem I noted during installation was a failure of backing up database. There was no prompt for ‘Press [Enter] key when database is updated/installed.’ I still get a blank page when trying to go to http://<ipaddress>/fog/management and mysql still shows the same four databases (none for FOG).


  • Senior Developer

    @TRex No.

    I think if you’re willing to jump around, please jump to what will be released soon, vs going back and forth. I don’t jump back and forth unless I absolutely have to and only to find a specific cause of a change.

    Since I know the ALTER user stuff hasn’t changed for quite a while, the only other thing I can think is a change in Ubuntu’s layout structures. This caused a change in representation to mysql for localhost which is why you see the code change I’ve added in the earlier posting. I’ve made this change based on my own findings in an attempt to help correct any potential issues in the future regarding localhost/127.0.0.1 representation.



  • @Tom-Elliott
    Would installing an earlier version (after re-installing OS) work? I’m not sure how I would install a RC, don’t even know if your addition has been added to RC.



  • @acole said in Can't access FOG Management Portal after clean OS and FOG install:

    @Wayne-Workman

    So, If I modify /opt/fog/.fogsettings to reflect the correct MySQL password, will that take care of it?

    Changing stuff inside of /opt/fog/.fogsettings and then re-running the fog installer will make the settings you set become ‘in use’, plus the installer will re-use these settings the next time it’s run, be it this version of FOG or a future one.


  • Senior Developer

    It has nothing to do with the /images location.

    The problem is to deal with localhost vs. 127.0.0.1

    Something switched on us apparently, as the code for handling alter user appears to have now changed in some way (even though the scripts handling this interaction hasn’t).

    I’ve added a bit of a fix hopefully in the working-1.3.5:
    https://github.com/FOGProject/fogproject/commit/9acc65bcb9fa6ea50facfc38615f7400b0afcc26#diff-c7d534e343a3d117623765442be0d709

    I don’t know if it will work, but I suspect it will make things a little bit more managable.



  • Perhaps a factor:
    /images
    is mounted at /dev/sda6



  • FOG version: 1.3.4
    OS: Ubuntu Server 16.04 (virtual under Hyper-V)

    Clean install of Ubuntu Server (partitions formatted)
    Clean install of FOG

    The install process seems okay except for:

    • Copying new files to web folder…OK
      find: `/home//fog_web_1.3.4.BACKUP/management/other/´: No such file or directory
    • Creating config file…OK

    But when I get to:

    • You still need to install/update your database schema.
    • This can be done by opening a web browser and going to:

    http://IPaddress/fog/management

    • Press [Enter] key when database is updated/installed.

    I use a browser to go to the IP address and get the default Apache page, but if I add /fog/management I get a blank page with a 500 error.

    Firewall is disabled.

    The only databases listed in MySql are (1) information_schema, (2) mysql, (3) performance_schema, and (4) sys



  • @Wayne-Workman

    So, If I modify /opt/fog/.fogsettings to reflect the correct MySQL password, will that take care of it?



  • This post is deleted!


  • @acole said in Can't access FOG Management Portal after clean OS and FOG install:

    Modifying the credentials for the MySQL user in /var/www/html/fog/lib/fog/config.class.php to match the root password.

    Not a good idea. You set mysql credentials and all other things inside of /opt/fog/.fogsettings
    Without modifying it in this place, the next time you re-run the installer the custom changes inside of config.class.php will be erased. Without doing it right, you’re just going to have the exact same issues the next time.

    See these articles for details:
    https://wiki.fogproject.org/wiki/index.php?title=.fogsettings
    https://wiki.fogproject.org/wiki/index.php?title=Password_Central



  • I finally got the installation to finish successfully by:

    • Upgrading Ubuntu to 16.04
    • Completely uninstalling FOG and deleting the fog user
    • Creating the FOG database manually
    • Modifying the credentials for the MySQL user in /var/www/html/fog/lib/fog/config.class.php to match the root password.

    I was able to create the schema and login to FOG, so now it looks like it’s working again. No idea why FOG had trouble creating the DB on a clean install of Ubuntu…


  • Senior Developer

    Is your mysql root user password blank? If it is, would you mind trying:

    mysql -u root
    ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY '';
    ALTER USER 'root'@'127.0.0.1' IDENTIFIED WITH mysql_native_password BY '';
    quit
    

  • Moderator

    @acole Could you post the foginstall error log here?

    Located in your git folder/bin/error_logs


Log in to reply
 

324
Online

7.4k
Users

14.5k
Topics

136.5k
Posts