Fog management accessable, but LOG files show database connection error...



  • I am struggling with a new/first time FOGSERVER install.

    I can connect successfully to the Fog management screen, and manipulate options, settings and tasks, but I am having NO luck with clients succesfully doing any pxe menu options such as Register, Debug, Quick Image (which asks for a password - which I have tried all the ones I know) (can’t get past this) not only this, but from the management screen, the LOG VIEWER shows - “unable to connect to database - retrying next iteration…” (not in front of unit now, but the error is something to that affect)
    But, I can manually connect to MYSQL using the FOG user and the FOG MYSQL password…

    I am sure this is a great package, when it works, although the various config files are quite spread-out and convulted, to say the least.

    Thanks.


  • Moderator

    If my fog server is inside virtualbox along with the test clients, it works fine for me. I have not yet tried to register a virtualbox guest from a fog server that is outside the host. I don’t know how that works.



  • [quote=“Phillip, post: 4625, member: 1479”]I was actually trying to just do a basic “inventory” on a VirtualBox image of Windows XP SP3, just for starters.[/quote]
    Phillip,
    When you do your quick inventory of your Virtual Machine, fog will use the MAC address for the name of the host and store the MAC address of the host. Go to your web GUI and log in then go to Host management, then list all hosts, you should see entries for your new hosts with a MAC address for a computer name. I havent had much luck working in VirtualBox, but have had great luck with VMware player.
    I am setting up a new fog server right now, in a VMware environment, and will play around with a VirtualBox machine to see if I can get it to do quick registration for me.



  • [quote=“chad-bisd, post: 4622, member: 18”]What model of machines are you trying to image? Are they all the same? If not, have you tried registering different models and gotten the same results? This could be as simple as needing a different kernel.[/quote]

    I was actually trying to just do a basic “inventory” on a VirtualBox image of Windows XP SP3, just for starters.


  • Moderator

    What model of machines are you trying to image? Are they all the same? If not, have you tried registering different models and gotten the same results? This could be as simple as needing a different kernel.



  • [quote=“chad-bisd, post: 4618, member: 18”]There are two spots that require the mysql password for a normal 1 server Fog install. 1 is for the Web UI, 1 is for the FogImageReplicator service. The error you are getting is related to the FogImageReplicator service. If you tail the log file, you’ll probably see it when you stop and restart the service.

    I don’t know if this will help your issues with the PXE menu options not working, but it may resolve your issue with error in the log file.

    To set a quick image password, you have to set a master password. Once you have set the master password, you can edit the passwords for individual tasks. For a normal “Full Host Registration and Inventory” you should NOT need a password unless you’ve set one for the fog.reginput setting in the Web UI.

    Are you stuck trying to select a task and getting blocked by a password requirement, or are the tasks scheduling and what you expect to happen is not happening?[/quote]

    [B]Thanks, I will test this evening, and let you know.[/B]

    [B]I have no master password set for pxe menu options, nor any individual options (DEBUG) etc… It will launch a Host Registration and Inventory but it just keeps scrolling on the screen after showing a blank MAC and SDA1, then the FOG graphic will slowly scroll up the screen with no further data on the screen. I always have to abort this.[/B]

    [B]I will try more later, at work now and have no access to home network.[/B]


  • Moderator

    There are two spots that require the mysql password for a normal 1 server Fog install. 1 is for the Web UI, 1 is for the FogImageReplicator service. The error you are getting is related to the FogImageReplicator service. If you tail the log file, you’ll probably see it when you stop and restart the service.

    I don’t know if this will help your issues with the PXE menu options not working, but it may resolve your issue with error in the log file.

    To set a quick image password, you have to set a master password. Once you have set the master password, you can edit the passwords for individual tasks. For a normal “Full Host Registration and Inventory” you should NOT need a password unless you’ve set one for the fog.reginput setting in the Web UI.

    Are you stuck trying to select a task and getting blocked by a password requirement, or are the tasks scheduling and what you expect to happen is not happening?



  • [quote=“chad-bisd, post: 4613, member: 18”]Did you set a password for the “root” user of MySQL?

    If you did, then you need to edit /opt/fog/service/etc/config.php and specify the password. This is for the FOGImageReplicator service to check its status and know if it needs to push images to other storage nodes.[/quote]

    [B]I did synchronize these passwords, (when these are not in-sync it will not even open the fog/management page.)[/B]
    [B]I have solved that problem early on. [/B][B]I can to the management portal fine. [/B]
    [B]I had MySQL installed prior to installing FOG, so I was aware that I had to edit the config.php file to sync these two.[/B]

    [B]I still just keep getting an error in the LOG VIEWER stating “cannot connect to database…”[/B]


  • Moderator

    Did you set a password for the “root” user of MySQL?

    If you did, then you need to edit /opt/fog/service/etc/config.php and specify the password. This is for the FOGImageReplicator service to check its status and know if it needs to push images to other storage nodes.


Log in to reply
 

442
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.