Client system will not load pxe image



  • Server
    • FOG Version: 1.3.3
    • OS: CentOS 6.8
    Client
    • Service Version:
    • OS: Windows 10

    To start with, I know very little about Linux, so please, treat me like I’m stupid. I had some help getting CentOS installed and then getting FOG installed, but, it’s not working so well. The machine, a brand new out of the box Dell OptiPlex 3040 will boot to the FOG menu, but no matter what I choose, that’s as far as I get. If I try a Full Registration, Quick Registration or Client System Information I get bzImage…ok & init.xz…ok and then nothing, it just hangs there. Memtest is similar, memdisk…ok, memtest.bin…ok, then hang.

    Remember, I’m a Linux newb, go easy on me! I will even get someone remote access if they know the answer to the problem but it would be too difficult to explain versus just fixing it.


  • Senior Developer

    @rbasart Well, that certainly could do it I suppose.

    As far as it “partially” working, the switch IS the IP address, and FOG had “listeners” on that IP.

    As the switch received the data, the FOG Server would perk up as well.

    Glad you figured it out for sure there. Sorry I didn’t recognize this, but hey one more thing to “look” for.



  • I just love coming to work at a company where the previous IT guy had his head firmly implanted in his sphincter!!! Because of his poor documentation or lack thereof in some cases, I had assigned the same IP as a switch on the network to the Linux box. I don’t know how Fog was working at all but it was getting by just enough to screw with a lot of people! Once I found out the duplicate IP situation and changed the IP of the switch, everything started working exactly as it should! Thanks to everyone for their help, especially Tom!



  • Another twist to the mystery. I tried to boot an HP EliteBook to Fog and got to the menu, but when I choose either the Full or the Quick, it starts to go, but then restarts the laptop. Any ideas?



  • So, thanks to Tom, we’re getting closer anyway. After a fresh install and a few tweaks, we are back to where this thread started but, it did work on a Lenovo laptop. Still not the Dell that I’m really shooting for.
    0_1486131169483_PXE boot.jpg



  • @rbasart The normal reason you don’t have this is the fog installed failed before it finished installing. .fogsettings is the last thing it does. Can you re-run ./install.sh and see if anything says “failed” please?



  • @kibade There is no .fogsettings there for me.



  • @rbasart Can you check for me what you have under /opt/fog/.fogsettings

    I’m most interested if your sql user fog password matches
    snmysqluser=‘fog’
    snmysqlpass=’’



  • @Tom-Elliott Tom thanks for the pointer, but it’s still not flying. At the end of the install, where it’s updating the database it fails. Everything else is okay. I did do a “service mysqld status” command and it comes back running, but I still get the “Your database connection appears to be invalid.” page.


  • Senior Developer

    @rbasart https://forums.fogproject.org/topic/9405/cannot-see-web-interface-i-have-apache-errors/13#
    Please give this a shot. In particular the installation instructions.



  • Per a suggestion here, I updated to version 1.3.4 to see if that would solve the problem, but now I’m stuck with a whole new issue.

    Database Schema Installer / Updater
    Your database connection appears to be invalid. FOG is unable to communicate with the database. There are many reasons why this could be the case. Please check your credentials in /var/www/html/fog/lib/fog/config.class.php. Also confirm that the database is indeed running. If credentials are correct, and if the Database service is running, check to ensure your filesystem has enough space.

    To top it off, when I try to restart mysql, it comes back as an unrecognized service.



  • @george1421 Choosing the Client System Information (Compatibility) option produces the same result. bzImage… OK and init.xz… OK


  • Moderator

    @rbasart I just sent you an IM. (little talk bubble on the forum tool tray at the top).

    IM should give us a quicker turn around for the Q&A session.



  • @george1421 Yep undionly.kpxe and 10.1.1.26 is the IP address of that box.


  • Moderator

    @rbasart After you have verified the dhcp options, pxe boot into the FOG iPXE menu and select the FOG compatibility options (near the bottom of the iPXE menu) and test the network and disk.


  • Moderator

    @rbasart Ok since the system is in legacy (bios) mode you should have your dhcp option 67 {boot-file} set to undionly.kpxe (typically) and for dhcp option 66 {next-server} that should be set to the IP address of your fog server.

    I know you may have already done this, but lets be sure we are consistent. I do have the 7040s on my campus so I know that in legacy mode undionly.kpxe does work.



  • The PC is in legacy mode and the legacy option ROMs are enabled. Secure boot is disabled. The drive is in AHCI mode and is a 500GB mechanical SATA Toshiba mo01acf050. The UEFI is not enabled in the PXE boot network stack.


  • Moderator

    @rbasart Lest first focus on the client.

    You have a new 3040. Is that computer in bios (legacy) mode or uefi mode? If you don’t know off the top of your head, check the firmware and see. If the computer had win10 on it from Dell then its probably in uefi mode.

    If its in uefi mode, you need to send ipxe.efi via dhcp and also ensure that secure boot is off.

    Also it would be handy to know if the hard drive is a sata ssd or a nvme (M.2) hard drive.



  • I have in my tftpboot directory intel, ipxe, realtek and undionly files with .kkpxe, kpxe and pxe extensions. I have tried all of them with no success. The only thing I can say for sure is that the intel series doesn’t work at all. All of the rest at least get me to the menu, but the result after that is the same.



  • I started with undionly.kpxe, then tried ipxe.kpxe, intel.kpxe and realtek.kpxe. I have not tried any *.kkpxe as I didn’t know that was an option. I will start running through them now. Also, I would have no idea how to change to ipxe7156 over ipxe.efi. The only reason I can change the boot file is because my DHCP server is on a Windows 2012 box, something I do know something about.


Log in to reply
 

455
Online

38930
Users

10694
Topics

101468
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.