Database Schema IU Error



  • Server
    • FOG Version: 1.3.0 RC13
    • OS: ubuntu 16.04
    Client
    • Service Version: latest (1.3)
    • OS: Win 7 pro X64
    Description

    Hi,

    Since a few day, my fog server wont work anymore. I’ve got this when i try to acces to the service :
    0_1485258911550_dsIU.png

    So after some research, it appears that the upgrade of PHP (V7) might be the cause of thoses errors. I try to upgrade to the latest version (1.3.4) but now i’ve got this :
    0_1485259090692_install.png

    I can’t install or use it anymore…



  • @Tom-Elliott I was in the good folder, but the trunk install didn’t work. I havn’t the screenshot anymore but the installation was stuck at “install and update package… Failed”. Like i said, i tried to install/update fog in many ways. I still don’t know why it didn’t want to install (when in was at /root/fogproject/bin) but this is not really important. V1.3.4 is running great, i’ve no issue since yesterday.


  • Senior Developer

    @educapole If you’re not properly in the bin folder, these issues would occur because it doesn’t know how to function. You would end up with a log of strange things that might partially run through.

    Just follow the installation instructions and make sure you’re in the fogproject/bin directory.



  • @Tom-Elliott When i took the screenshot, i wasn’t in the good folder indeed… So now it works, even if i don’t anderstand why it wont before. If you don’t mind, i want to let this topic “unsolved” a few time because this is the third time in a couple of days that i’ve have Database Schema I/U error. I think its because i wasn’t able to upgrade to 1.3.4. Thanks both of you


  • Senior Developer

    @educapole What do you mean?

    THe installer is giving the same information, or your going to the GUI is still showing as “invalid”?



  • I tried to install in many ways, i’ve got the same message even if i’m in the folder (cd /root/fogproject/bin)


  • Senior Developer

    Also, when installing FOG, we aren’t using a basepath pattern to find files, we use relative paths as basepath patterns would still have a hard time finding the required files.

    Running the installer with ./bin/installfog.sh is not viable. You must first: cd bin then ./installfog.sh


  • Moderator

    Try to restart MySQL first. Details here: https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_MySQL

    Also 1.3.0 RC 13 is pretty old, we actually have stable releases now. I would suggest you try upgrading to FOG 1.3.3.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.