Still getting Error 500/Multiple Hosts Returned for list of MAC addresses after 1.3.4 RC-2



  • Server
    • FOG Version: 1.3.4 RC-2
    • OS: Debian 8.6
    Client
    • Service Version: v0.11.8
    • OS: Windows 7
    Description

    My FOG clients are still having this issue after a reboot or two.

    Here’s where it starts. I had just finished installing my snap-ins:

    ------------------------------------------------------------------------------
    ----------------------------------UserTracker---------------------------------
    ------------------------------------------------------------------------------
     1/23/2017 2:20 PM Client-Info Client Version: 0.11.8
     1/23/2017 2:20 PM Client-Info Client OS:      Windows
     1/23/2017 2:20 PM Client-Info Server Version: 1.3.4-RC-2
     1/23/2017 2:20 PM Middleware::Response Success
    ------------------------------------------------------------------------------
    
     1/23/2017 2:20 PM Service Sleeping for 150 seconds
     1/23/2017 2:23 PM Main Overriding exception handling
     1/23/2017 2:23 PM Main Bootstrapping Zazzles
     1/23/2017 2:23 PM Controller Initialize
     1/23/2017 2:23 PM Zazzles Creating main thread
     1/23/2017 2:23 PM Zazzles Service construction complete
     1/23/2017 2:23 PM Controller Start
    
     1/23/2017 2:23 PM Service Starting service
     1/23/2017 2:23 PM Bus Became bus server
     1/23/2017 2:23 PM Bus {
      "self": true,
      "channel": "Status",
      "data": "{\r\n  \"action\": \"load\"\r\n}"
    }
     1/23/2017 2:23 PM Bus Emmiting message on channel: Status
     1/23/2017 2:23 PM Service Invoking early JIT compilation on needed binaries
    
    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     1/23/2017 2:23 PM Client-Info Version: 0.11.8
     1/23/2017 2:23 PM Client-Info OS:      Windows
     1/23/2017 2:23 PM Middleware::Authentication Waiting for authentication timeout to pass
     1/23/2017 2:23 PM Middleware::Communication Download: http://10.4.200.150/fog/management/other/ssl/srvpublic.crt
     1/23/2017 2:23 PM Data::RSA FOG Server CA cert found
     1/23/2017 2:23 PM Middleware::Authentication Cert OK
     1/23/2017 2:23 PM Middleware::Communication POST URL: http://10.4.200.150/fog/management/index.php?sub=requestClientInfo&authorize&newService
     1/23/2017 2:23 PM Middleware::Response Error multiple hosts returned for list of mac addresses
    
    

    And then the 500 Error again

    ------------------------------------------------------------------------------
    --------------------------------Authentication--------------------------------
    ------------------------------------------------------------------------------
     1/23/2017 2:35 PM Client-Info Version: 0.11.8
     1/23/2017 2:35 PM Client-Info OS:      Windows
     1/23/2017 2:35 PM Middleware::Authentication Waiting for authentication timeout to pass
     1/23/2017 2:37 PM Middleware::Communication Download: http://10.4.200.150/fog/management/other/ssl/srvpublic.crt
     1/23/2017 2:37 PM Data::RSA FOG Server CA cert found
     1/23/2017 2:37 PM Middleware::Authentication Cert OK
     1/23/2017 2:37 PM Middleware::Communication POST URL: http://10.4.200.150/fog/management/index.php?sub=requestClientInfo&authorize&newService
     1/23/2017 2:37 PM Middleware::Response Error multiple hosts returned for list of mac addresses
    
    
     1/23/2017 2:37 PM Bus Registering ParseBus in channel Power
     1/23/2017 2:37 PM Middleware::Communication URL: http://10.4.200.150/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     1/23/2017 2:37 PM Middleware::Response Success
     1/23/2017 2:37 PM Middleware::Communication Download: http://10.4.200.150/fog/management/other/fog_client_banner.png
     1/23/2017 2:37 PM Middleware::Communication URL: http://10.4.200.150/fog/management/index.php?sub=requestClientInfo&mac=18:03:73:2D:1E:CB|00:50:56:C0:00:01|00:50:56:C0:00:08||00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0|00:00:00:00:00:00:00:E0&newService&json
     1/23/2017 2:37 PM Middleware::Communication ERROR: Could not contact FOG server
     1/23/2017 2:37 PM Middleware::Communication ERROR: The remote server returned an error: (500) Internal Server Error.
     1/23/2017 2:37 PM Middleware::Response Success
     1/23/2017 2:37 PM Middleware::Communication URL: http://10.4.200.150/fog/service/getversion.php?clientver&newService&json
     1/23/2017 2:37 PM Middleware::Communication URL: http://10.4.200.150/fog/service/getversion.php?newService&json
    
     1/23/2017 2:37 PM Service Creating user agent cache
     1/23/2017 2:37 PM Middleware::Response ERROR: Unable to get subsection
     1/23/2017 2:37 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     1/23/2017 2:37 PM Middleware::Response ERROR: Unable to get subsection
     1/23/2017 2:37 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     1/23/2017 2:37 PM Middleware::Response ERROR: Unable to get subsection
     1/23/2017 2:37 PM Middleware::Response ERROR: Object reference not set to an instance of an object.
     1/23/2017 2:37 PM Service Initializing modules
    
    

    Thanks guys


  • Senior Developer

    @Wayne-Workman I’ve already cleaned it up.


  • Moderator

    I’m going to guess that the bad data in the tables hosts and hostMAC lingered after the tables were manipulated by the update - or the update failed due to the data being in the tables.

    We can probably construct a query to clean it up. I can look into it more later tonight.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.