Looping capture 1.3.3.



  • Debian Jessie
    • FOG 1.3.3
    • OS:
    Client
    • Service Version:
    • OS: win 7 pro 64Bit

    I upgraded from 1.2.0 to 1.3.1, then 1.3.2 then 1.3.3. I missed the error that UPDCast was failing each upgrade because my tmp partition was set to noexec. Once corrected and re-run./install.sh, found ./fogsettings had the wrong storage location, mysql user and password. Corrected, but found apache configs weren’t all over the place. I cut my losses and removed fog, erased mysql and purged apache and re-installed. This looked good. Registered a few computers and captured an image. All looks good, /images/dev image gets created, but when it finishes, the computer restarts, it restarts the capture, saying “one active task”. It starts over writing the image in /dev/
    Currently, I’m not on site, I’m remoted in, so if an error message comes on the screen at the end of imaging, I can’t see it.
    Any help on how to get passed the capture so it can move the captured image to /images and finishes the task would be really appreciated.


  • Moderator

    @kibade cool beans.

    The troubleshooting articles most times will lead you to the problem if nothing else. Glad to see they are still helping folks.



  • @Wayne-Workman Thanks for yours and Toms advice. It’s working :-)

    I found the Linux user “fog” password had changed. Must have missed that on the upgrade. I found it by trying to connect via ftp from a windows machine to the fog server as per : https://wiki.fogproject.org/wiki/index.php?title=Troubleshoot_FTP#Try_to_get_a_file_with_Windows:

    I still found the capture looped, I found in the apache/error.logs the following:- (bold is the important bit)

    [Mon Jan 23 14:18:52.008806 2017] [:error] [pid 22907] [client 192.168.0.207:46956] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘Type: 2, File: /var/www/fog/lib/fog/fogftp.class.php, Line: 708, Message: ftp_put(/images/dev/64006a90ca4a): failed to open stream: No such file or directory, Host: 192.168.0.3, Username: fog’ in /var/www/fog/lib/fog/fogftp.class.php:367\nStack trace:
    n#0 /var/www/fog/lib/fog/fogftp.class.php(772): FOGFTP->ftperror(Array)\n#1 /var/www/fog/lib/reg-task/taskqueue.class.php(366): FOGFTP->rename(’/images/dev/640…’, ‘/images/Default…’)\n#2 /var/www/fog/lib/reg-task/taskqueue.class.php(413): TaskQueue->_moveUpload()\n#3 /var/www/fog/service/Post_Stage2.php(24): TaskQueue->checkout()\n#4 {main}\n thrown in /var/www/fog/lib/fog/fogftp.class.php on line 367

    My storage location is /var/backups/images

    I looked back into the fog storage management setting and noticed something I had over looked, we have an extra setting FTP path.
    It was set to /images, I corrected to /var/backups/images.

    The original storage path was correct.

    Works now :-)


  • Senior Developer

    @kibade I’m seeing your permissions appear to be backwards.

    The owner should be fog:root, but yours currently are set as root:fog.

    The /images and dev directories are set as 775. This, typically, should be fine, but because of how the ownership is I think this is your issue.

    Please change them so the ownership is fog:root (with chown -R fog:root) and the permissions are 777 with (chmod -R 777 /images)



  • @Tom-Elliott Thanks for the quick reply :-)
    So before you response the /images perms were:-
    drwxrwxr-x 3 root fog 4096 Jan 19 10:48 images
    drwxrwxr-x 3 root fog 4096 Jan 19 16:41 dev
    And in dev the captured image :
    drwxrwxrwx 2 root root 4096 Jan 19 21:55 64006a90ca4a
    I’ll try the perm change today and see what happens. I’m still a long way away to physically see the computer being imaged. I’ll report back if you suggestion helped.
    Thanks.


  • Senior Developer

    This can also occur if the permissions are not set properly for the FOG user.

    For example, if the ownership is root:root and permissions are 755 then you will run into this as well, as the fog user moving the files cannot move them into the /images folder.

    The Installer should take care of this for you, but there are cases where this still could happen unknowingly.

    Please try making sure permissions are correct by running:

    chown -R fog:root /images
    chmod -R 777 /images
    

    I think you will find the upload process should complete.


  • Moderator

    Just a guess, but it sounds like FTP credentials are not right if the captured image is staying in /images/dev which is unusual for fog 1.3.3 because when the installer is run it ensures the credentials are set properly - unless they were changed after the installer ran.

    You’re going to need to watch the capture process with a laptop on your lap to also watch the task management page in FOG. Towards the end of the capture pay attention. Does the capture task clear? What messages are displayed on the machine’s monitor? Grab a video of it with your smart phone to capture the exact messages. Then share with us exactly what’s happening.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.