no such device or address

  • Server
    • FOG Version: 1.3.2
    • OS: Ubuntu 16.04 server
    • Service Version:
    • OS: Windows 10

    I have “no such device or address” in fog for all host.

    The automatic hostname change its ok but not the domain integration.

    For ubuntu server 16.04:

    • ping “hostname” - Failed
    • ping “IP host” - OK
    • ping - OK
    • ping “hostname.domaine” - OK


  • Hi, Was this issue resolved?
    I have a same or similar issue where the host status is green for about the first ten minutes till i register the host image it, but after a while fog says ‘no such device or address’

    Given the age of the issue, has it been fixed or I have to follow the SQL edit procedure?

  • Now :

    • Ping its OK
    • Cloning its OK
    • Hostname changer and registration domain - Failed. But i think is a client, I will do several tests and I will post a new topic if I have a problem.

    Very thank for this help.

  • Senior Developer

    Remoted in and added:
    search <domain name> to the /etc/resolv.conf file.

    I don’t know if this will be automatically added or not, but hostnames by themselves are now pingable from the fog server.

  • Senior Developer

    I should add, this is specific to the ipxe error that was being seen. Everything else, however still holds true.

    If others are hitting similar snags there’s a way to fix. It’s two SQL statements needed and some information gathering first.

    In mysql you would run (while on the fog database):

    SELECT settingKey,count(*) c, MAX(settingID) FROM globalSettings GROUP BY settingKey HAVING c > 1;

    This might output something like:

    | settingKey | c | max(settingID) |
    | FOG_GRACE_TIMEOUT | 2 | 191 |
    | FOG_LOGIN_INFO_DISPLAY | 2 | 192 |
    | FOG_PXE_MENU_TIMEOUT | 2 | 73 |
    | FOG_USED_TASKS | 2 | 190 |

    The last column (the max(settingID) field) is what we’re interested in.
    With this info you can then run:

    DELETE FROM globalSettings WHERE settingID IN (191, 192, 73, 190);

  • Senior Developer

    I was chatting with @sapeurorca yesterday and had him run a few tests in light of the schema update issues. These tests had added duplicate keys into the globalSettings table.

    The problem that was being seen is from more data being returned than what was actually being requested (because of the duplicate entries.)

    You can actually see the problem in the browser code too. In the browser we tend to not have users sending an arch value. This means any browser url will send out the 32 bit files.

    If you look in the returned output from earlier, however, you will see it’s setting the kernel to bzImage (when it should be bzImage32).

  • Moderator

    @sapeurorca Well I see your error in the boot.php page.

    For both the bzImage and the init.xz files, they are missing the path to the files.


  • yes i tried several times with same error messages.

  • Developer

    @sapeurorca On first sight the output looks pretty good to me! I am really puzzled from the 5... No such file or directory... message in your last picture. Have you tried several times? Do you always get the exact same error messages?

  • 0_1484734345131_3.JPG

  • Developer

    @sapeurorca Please open the following URL in your browser and post the full output here:

  • I have another error for clonning : “no such file or directory (http//”


    thank you for this help.

  • In /etc/resolv.conf i have my DNSserver and i do not have dnsmasq.

    I am switching from Ubuntu 13.04 to 16.04 with update.

    If ubuntu is not on AD, is it possible that this causes this problem?

  • Moderator

    What do you have setup for dns name resolution on the FOG server?

    Hint: inspect /etc/resolv.conf This should probably point to your on site (AD) DNS server.

    The answer may change if you are running dnsmasq on the FOG server too.