Upgrade from 1.2 to 1.3



  • I see 1.3 was officially released not long ago and I was looking to upgrade my server to it. However, When I attempted to upgrade to 1.3 it failed. Currently i’m on Ubuntu 14.04. Looking at another topic I see you guys recommended migrating from 14.04 to 16.04.

    Is my only option to Migrate FoG to a new server?

    Will future updates be like this as well?


  • Moderator

    In plainer terms, you can update Ubuntu from an older version to a newer one - sure. But if it fails or leaves fog crippled, we don’t just “know” what went wrong. We don’t know how the old OS was setup, what was installed, how it was configured, and so on. It can be troubleshooted but how long that will take or if it’s successful or not, I can’t tell you. The Developers and Moderators and other community members are normally willing to help people - but your pace is limited to their free time.

    So… Last night I wrote an article about migrating fog. For this - we know all the steps, and it’s less risky - and you can follow along with it and work at your own pace instead of relying on us.

    If you’re strong with Linux and you’re Google-Foo is up to snuff, sure upgrade your OS. If you’re a newbie in a crunch don’t want risks, migrate.



  • @Tom-Elliott Thanks for the immediate response Tom!

    I love the community FOG offers!


  • Senior Developer

    While we try to remain somewhat backward compatible, some times the efforts of others influence the efforts we can take.

    Upgrading from Ubuntu 12, 13, 14 from 1.2. to 1.3.0 used to work, then suddenly stopped. This wasn’t because of something FOG has, or hasn’t done with the exception that to try to ensure things will continue to work I lookup a repository to get php and apache updated where FOG is expecting them to be.

    For Ubuntu, this is typically Ondrej ppa. However, relatively recently Ondrej’s repos appear to not have the php files, or I’m now magically calling them incorrectly.

    In the past, php install on ubuntu would be in form of: php5{-item}

    This used to be somewhat similar for ondrej only you would call the full version when php 7 was released (e.g. php5.6{-item} or php7.0{-item})

    The issue isn’t something fog is doing but rather something ondrej is removing or no longer supporting. I haven’t had time to switch around to use the new models for the older Ubuntu’s but I do know that upgrading to 16.04 will enable php to install properly.


Log in to reply
 

406
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.