Lenovo E560



  • Hi,
    I can’t image my brand new Lenovo E560 laptop. Using the same old generic image for my other models which still work great. I have disable secure boot and set legacy for pxe. I even wiped out any remaining partitions on the drive just in case it was the issue. I’m stuck here just after partclone :
    0_1484079162791_IMG_0305.JPG

    here is my fog version :
    0_1484079279153_upload-ea0c23d0-87d4-4ae7-ad92-7e8400abbf05

    and my image settings :
    0_1484079314404_upload-c15824c1-abb5-4ba9-af91-562010c32d33

    thanks in advance for your help !


  • Senior Developer

    @fritoss007 Then you might be better doing the fixparts methodology. Now I’ve added postinitscripts to the working branch data so things should be able to be automated much more nicely for those 18 or so systems you’re seeing with this issue. (You can add checks to get things working how you need it).



  • Hi Tom,

    now that I’m using “GRUB_FIRST_FOUND_WINDOW”, I have this on my others Win 8.1 Laptop :

    0_1484228183859_upload-875e2945-8105-4468-b8e7-d45beaf50ea6



  • sorry…i’m doing a godzillion things on my lunch time !! and my english is not that great too !

    anyway this issue was reported by one of my co-worker but I can’t reproduce it…so forget about it ! Sorry

    thanks Tom for your support your team saved me a lot of time again !


  • Senior Developer

    @fritoss007 Can you rephrase? I don’t understand what you’re trying to ask.



  • lol lol lol

    so what could be the issue now the system is not asking location and doing a full inventory from pxe menu of a new host ?


  • Senior Developer

    @fritoss007 No. Location is not an “automatic” thing. Locations are specified to the hosts. I’m not that good…yet.



  • I ran the wget…i’ll test it later today with another laptop…thanks

    and about the location, it really automatically decide which location to choose ?


  • Senior Developer

    @fritoss007 Regarging the posting I’m replying here:

    Location -> Use init’sand kernels from this node checkbox.

    When a host is associated to the Sept-Iles node, the checkbox makes the host download the init.xz and bzImage files from the location, otherwise it will try to do it from the server that is providing the pxe information.


  • Senior Developer

    @fritoss007 DId you run the wget I suggested?

    That should provide the fix for you.



  • automatically…you mean magicly ??? lol

    Tom, now I have 18 others with GPT partition how can I fog it without having to go through debug each time to clear the GPT?


  • Moderator

    @fritoss007 I could be wrong, but I believe it automatically choose the closest node to associate to.



  • Hi Tom,

    GRUB_FIRST_FOUND_WINDOWS did the trick ! thanks a lot !

    Now I have another question…when we full inventory and image a new computer from pxe menu the system does not ask location anymore…could this be the issue ?
    0_1484153462243_upload-9d6eb4a0-d3ea-42eb-9c32-669738011c93


  • Senior Developer

    You could also try GRUB_FIRST_FOUND_WINDOWS as it’s possible the 1st hdd grub is finding is not the disk that’s being expected to boot.


  • Senior Developer

    @fritoss007 Mind trying SANBOOT or EXIT for legacy? If your device is using UEFI to boot (which I don’t think it is) the EFI exit type should be either exit or rEFInd.



  • 0_1484150151685_upload-78661160-9ce3-4f9e-bb5e-4fa4b5f5eb07


  • Senior Developer

    @fritoss007 What’s the exit type for this system?



  • Hi Tom,

    thanks for your reply. I ran fixparts /dev/sda and it found a remaining GPT partition…seems like my disk wiping didn’t work properly ! I manage to kill this remaining GPT partition. I’ve re-image the laptop and now I have this :
    0_1484148225722_IMG_0306.JPG


  • Senior Developer

    Thinking more and more on this, while what I suggested (I suspect) should fix the hanging issue, I recalled the reasoning for what used to cause the same type of hanging on upload tasks. fixparts typically would fix this for you as well, but another user reported a kind of solution to the problem. I think you may have uploaded your image after this fix had been applied. However, this caused the other similar calls on the deploy side to potentially cause issues. The fix applied did not get applied to ALL sgdisk calls.

    https://github.com/FOGProject/fogproject/pull/143 is where this similar issue was kind of “fixed”. Essentially, as I understand it, we’re just piping an empty string into the gdisk calls. (Technical I realize, but useful I think.)

    Please try updating your init’s using the following:

    wget -O --no-check-certificate /var/www/fog/service/ipxe/init.xz https://fogproject.org/inits/init.xz
    wget -O --no-check-certificate /var/www/fog/service/ipxe/init_32.xz https://fogproject.org/inits/init_32.xz
    

    I hope this will get your Lenovo’s to complete the imaging process properly.


  • Senior Developer

    I believe your issue is the Disk is in GPT format, but receiving a legacy style partition layout.

    Normally we see this kind of thing on capture, but it is possible to happen on a download if the original partition layout doesn’t get cleaned up automatically. It “should” but GPT has a backup of the partition layout. My guess is sgdisk is waiting for some input of you to continue on.

    To validate this thought would you mind recreating a task, but before confirming the task check the debug box.

    After that, boot the system you tasked and wait for the terminal prompt to come to you (After you hit enter in the appropriate questions.)

    Please try running (once in the terminal) :

    fixparts /dev/sda

    Confirm if it asks and quit.

    Remove the debug tasking and see if you can complete the image.

    Please keep us as informed as you can.


Log in to reply
 

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.